DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   North East (http://www.ramforumz.com/forumdisplay.php?f=94)
-   -   2001 Dodge Ram 1500 5.2L Cat Problem (http://www.ramforumz.com/showthread.php?t=48988)

Quiet Lunatic 03-02-2010 09:45 PM

2001 Dodge Ram 1500 5.2L Cat Problem
 
Had dual exhaust put on by Lou's Exhaust in New Hampshire. Great Sound but plenty of problems that I never had before. 420 Reading with engine light on. New Cats, O2 Sensors, on cold mornings truck will stall and I have to warm up for 10-15 minutes and rev it up. I use the high grade gas. Any ideas on why truck stalls and low rpm when starting?

deanthecrabman 03-02-2010 10:15 PM

Not sure what that code is, but welcome to the forum anyways. Might want to go the the user CP and fill out your profile. Then all the data for your truck will come up in the upper right corner with every post. Someone will chime in soon.

Toms Blue Ram 1500 03-03-2010 12:14 AM

Might try cleaning the throttle body bore and plate . Start with that and see what it does for ya . Let us know how you make out .

ramHD 05-19-2010 12:22 AM

PO420? that should be a cat converter efficiency code. your converter is not working, or there is an issue with the downstream O2 sensor. some aftermarket cats just dont cut it as far as being able to store the same amount of O2 as the OE cats do. also I have seen people install the wrong O2 sensor in the down stream (after cat) position. can cause all kind or running and driveability issues. the other weird thing I have seen is a problem with the trans solinoid packs going bad and causing the computer to think the downstream O2 is shorted.


All times are GMT -4. The time now is 12:42 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger