DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Suspension (http://www.ramforumz.com/forumdisplay.php?f=192)
-   -   '04 Ram 1500 front axle trouble (http://www.ramforumz.com/showthread.php?t=50554)

04blueram 03-31-2010 08:46 PM

'04 Ram 1500 front axle trouble
 
First off, I'm new to the site, so Hello All!!!:beerchug:

I bought my '04 reg cab Ram 1500 4x4 4.7L about 8 months ago with what I am guessing is about a 3" lift. I took it out in the local sand dune area over the summer (Silver Lake, MI) and it handled/drove beautifully. I took a break for a bit, then was just taking off and taking it easy and something snapped. I had no drive from any of the wheels. Once I took it out of 4wd, I had drive from the rear wheels again. My thought was that I had snapped the chain in the transfer case or something.... I recently took it to a local shop to have it checked out and they quoted me $6,000 to fix it! They said the problem was that the angle from the front differential to the wheel hubs was too great. To fix the problem they told me I would need some sort of lowering bracket for the differential. I don't know the brand of lift kit or who installed it so I have no reference point to start with. Can someone please give me some advice on what to do here? I would really appreciate any information that anyone can give me.
Thanks in advance!!
-Mike

04blueram 04-01-2010 08:25 AM

Moderator: Please delete this post, I've reposted it in the suspension forum where it should have been in the first place. Thanks!

erm 04-01-2010 08:28 AM

Thread closed.


All times are GMT -4. The time now is 11:07 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger