DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Custom Dodge Ram Interior and Exterior Lighting (http://www.ramforumz.com/forumdisplay.php?f=78)
-   -   AAC Interior Light issue (http://www.ramforumz.com/showthread.php?t=54103)

Quiet Lunatic 05-25-2010 04:19 PM

AAC Interior Light issue
 
Hey Everybody,


I purchased the interior kit and the reverse light kit from AAC and I absolutely love everything except for one small issue. The interior Map Lights stopped working, I know the polarity is correct because they were working but now they are out. I have contact AAC and I am sure they will make good on the issue, but I was curious if anyone else had a similar issue. Thanks


Phil

hemiv8dodgeram1500 05-29-2010 07:10 PM

just bumping it up

Quiet Lunatic 05-29-2010 09:12 PM

Thanks for the help I could use it. Unfortunately my truck has given me headaches with anything I throw at it aftermarket in the realm of electrical. I was hoping someone could point me in the right direction. Thanks again

erm 05-29-2010 09:15 PM

It may be a voltage issue. I know they solved my HID problem so I hope they can solve your interior light issue.

CdnoilRAM 05-29-2010 09:19 PM

I use the same Oracle LEDs that AAC sells, and for the most part they're the best I've been through. Another guy I know has a power spike of up to 18V when he turns them on, and the LED bulbs have a max voltage of 14V, so this does cause them to have a much shorter life. I believe it's an issue with the TPCM, which may be a reason for your other electrical issues as EVERYTHING electrical runs though it.

Quiet Lunatic 05-30-2010 07:55 PM

TPCM? I am not familiar.

MightyBlueRam 05-30-2010 10:56 PM

Any pics of what the lights look like?

Excoastie 05-31-2010 08:10 AM

You're not alone. I purchased a set of the interior lights LEDs as well. 1 of them worked for about a week, the others work great.

I should've called about it the day it stopped working, but got busy, and I never got around to it. I figure my time has run out to bitch and complain about it.

I'm not sure why this happened, I just know the passenger side map light stopped working. I tried swapping it with the drivers' side, and it still didn't work. The old #194 still works, so that is what I put back in


Exco

Quiet Lunatic 06-01-2010 08:58 PM

ACC told me that the Dodge runs 8v through the lights at certain times and can cause them to blow. They told me to wire in resistors but after spending $62 for five light bulbs I am really not at will to have to alter them to work properly. They said I can send them back and they will attempt to hook them up which is pretty cool on their part.


All times are GMT -4. The time now is 11:22 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger