DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Cummins Diesel Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=187)
-   -   07 dodge 3500 problems (http://www.ramforumz.com/showthread.php?t=57844)

mercel lugnut 07-23-2010 05:52 PM

07 dodge 3500 problems
 
i have an 07 3500 with the 5.9 and i keep getting the engine light every so often. When i take it to autozone the code is a voltage code for injector 4-6 and right after they unplug the little reader thing the light goes off. My question is what would cause this and how do i fix it? I have a diablo programmer on it but the actual programmer was stolen from me so now it is on my truck but i can't tune it or take it off. The dealership said that this might be covered under warranty but I know if I go up there with the programmer on it they are going to tell me that it is not covered. I need some help and some advise

RamTech 07-23-2010 05:54 PM

What's the P-code?

CdnoilRAM 07-24-2010 01:41 AM

Have you checked all the connections to the injectors as they may be loose or slightly corroded causing the intermittent voltage irregularity.

Toms Blue Ram 1500 07-24-2010 10:18 AM

I'm not sure what you have . Your question is posted in the Cummins section , talking about a 5.9 with a predator and having a 5.7 hemi in your profile . Can you confirm what your running .

mercel lugnut 07-24-2010 01:08 PM

I have several trucks the one i am talking about is a 5.9 diesel. It has a diablo programmer on it and I do not know what the codes were I accidently threw the piece of paper with them on it

Toms Blue Ram 1500 07-24-2010 02:06 PM

Not sure what you can do . I would say maybe try and get a used ecm and install that then take it in . Or just man up and take it in and bite the bullet . I don't think Diablosport can help you out . You may want to check with them .

cjames 07-29-2010 12:05 PM

man that harsh getting the programmer stolen id say get a new programmer and take the tune off and then get the problem fixed under warrenty

Diesel Geek 09-03-2010 10:24 PM

i have seen this before. the terminals on the bank 2 injector connectors spread apart just a bit, so every so often it will see high resistance. then pop the light on. very carefuly close the terminal on the connector just a bit. if that dont work then you will need to test the cross over harness and the engine harness for opens.

i work for a dodge dealership. if your in south carolina i could give you a hand with this.


All times are GMT -4. The time now is 08:24 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger