DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Heating & Cooling (http://www.ramforumz.com/forumdisplay.php?f=190)
-   -   AC Blower issue. (http://www.ramforumz.com/showthread.php?t=58787)

threetime 08-07-2010 04:52 PM

AC Blower issue.
 
Oh, by the way, hello everyone. Back to the problem. I think I already know the answer to this but here goes. I have an 04 dodge ram 1500 4X4. Two days ago the AC worked fine. Then after work, I got in, turned the AC on and it was barely putting out. I can hear the fan motor running fine. The hi, med, low works fine. The selector works fine. I think something came unhooked, like the main flow tube and its blowing the cold air in the dash. Question, anyone think I have a different problem? How hard is this going to be to fix?

threetime 08-07-2010 10:46 PM

***UPDATE***

OK, I have tore into the dash with amazing speed. The weird thing is I can see the top of the hvac unit and look all the way to the firewall and can see the freshair grill. I can stick my hand in there and it feels like the air is blowing out the vents and also where the fresh air comes in. I am not sure if there is some kind of flap that is not closing??? Help please.

RamTech 08-08-2010 10:55 AM

You've probably got a broken recirc door. Very common problem.

KC Chally Snob 08-15-2010 10:31 AM

Threetime,

I had the exact same problem up until yesterday. I got a new recirc housing, 75.00, from the local Dodge dealer, and proceeded to remove the dash. Now I have a 2003 1500 Quad cab and Randy was kind enough to have posted the instructions on how to remove the dash, but I didn't remove dash completely. I just took enough off, which would have allowed me to remove the dash because all the bolts holding it to the vehicle were removed, to pull the rights side of the dash back enough to get the old housing out and the new one in. Look here on the form for recirc door posts and you should be able to find Randy's earlier post with detailed intructions.
Good Luck.

KC Chally Snob
AKA Larry

wissuffa 09-18-2010 07:31 PM

simiar problem here 2003 Ram 1500 blower motor not blowing checked all the fuses and disconnected the blower motor did a test on it with the battery and it worked fine but when hooked to the connections it's not working anyone have similar issues

RamTech 09-18-2010 07:49 PM

Quote:

Originally Posted by wissuffa (Post 313382)
simiar problem here 2003 Ram 1500 blower motor not blowing checked all the fuses and disconnected the blower motor did a test on it with the battery and it worked fine but when hooked to the connections it's not working anyone have similar issues

Do you have power on the dark green wire to the blower motor with the key in the run position?

wissuffa 09-18-2010 08:48 PM

no power to green wire

RamTech 09-18-2010 09:21 PM

You have an ignition switch problem or a break in the green wire.

wissuffa 09-18-2010 10:04 PM

thanks, i just had to change te key cylinder and prior to that the blower would cut n-off and i thought it was the ignition switch but i changed the key cylinder thanks for the info much appreciated!!


All times are GMT -4. The time now is 09:22 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger