DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   4.7L PowerTech V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=205)
-   -   High Idle (http://www.ramforumz.com/showthread.php?t=64056)

sasdelivery713 10-19-2010 03:54 PM

High Idle
 
so, this past Sunday I cleaned the Throttle Body on my Ram and my dad's ram... they both r 4.7L.... but when i finished cleanin mine... my truck starting idling around 1000 to 1200 rpm's... as opposed to 550 to 750 Rpm's.... my check engine light isnt on.... and i took off everything back off and cleaning it once again?..... does any one have any suggetsions.... im thinkin it could be My TPS or IAC.... but i really dont know.... any help would be greatly appreciated!!!!

RamTech 10-19-2010 04:17 PM

Sure you didn't knock off a vacuum line somewhere?

sasdelivery713 10-19-2010 04:59 PM

i made sure to connect everything back... i didnt take any vacuum lines off.... and i didnt knock any off.... i took my TB back off today.... and redid everything... and it was stilll runnin around 1000 to 1200 rpm's.... im wonderin if it could b my TPS or My IAC... but my check engine light isnt on...

Toms Blue Ram 1500 10-19-2010 05:27 PM

Have you verifed the throttle plate is closing all the way ?


All times are GMT -4. The time now is 04:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger