DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Heating & Cooling (http://www.ramforumz.com/forumdisplay.php?f=190)
-   -   Still no A/C!! (http://www.ramforumz.com/showthread.php?t=64564)

blackout 10-26-2010 07:31 PM

Still no A/C!!
 
well i've been lurking around finding solutions for my A/C problem. at first it would on wok in the high fan setting(sometimes). so I checked the Fuses and relays under the hood, then after some research i found that the Resistor under the glove box could be the issue. I replaced it now the different fan settings work but only when it wants to. It has its own brain or something, its turns on when it want to, when the knob is at a fan setting. As i drive i can feel air through the ducts but not at the fan speed, the faster i go the more air comes in, and i can change it if i want it to the floor or at the top, or defrost.

Any clues, all relays and fuses are good, the blower motor works( tested it by direct current), and the resistor is new just replaced. Still no air comes out. :4-dontknow:

RootBeer 10-26-2010 07:39 PM

If I understand it correctly you cannot set the fan speed regardless of A/C or heat or vent, right?

You've checked fuses and relays and replaced the resistor for the motor. You've tested the motor with direct current.

That leaves only one thing in my mind, the switch itself.

blackout 10-26-2010 08:08 PM

once it decides to turn on i can change the blower speed, but only when it decides to turn on. i just keep it in high an pray it would turn on. But i guess it might be time for a new or used switch. :thk:

RootBeer 10-26-2010 08:11 PM

Well, if the motor works fine when under direct power it seems to me the only option is the switch or a short someplace.

If you can take the switch out, try connecting it between the motor and a direct power source. Then operate the switch and see what happens. I recommend at least putting a fusible link in-line for protection.

blackout 01-14-2011 04:33 PM

Alright I tried everything an still no A/C, but just a week a go I had to use my E-Brake and as i lifted the lever to disengage the brake the blower kicked on. So what seems to work for me is slamming the E-Brake release lever every time the fan doesn't want not start. It might be some relay or loose wire under the steering/pedal area but i'm good as is. I thought i might share my Experience to others that might be scratching their heads trying to make their a/c work.

SnowChief 01-14-2011 04:47 PM

I am sorry to hear your AC does not work and even more sorry that I cannot offer any technical suggestions.

I would be happy, however, to trade you some artic air (single digits farenheit right now) for hopefully warmer air where you live!!!!!!

blackout 01-14-2011 05:07 PM

haha!! No, im okay. its working now. but only if I slam the E-brake release real hard.

surfintazz 06-12-2011 10:05 AM

I have the EXACT same problem... will try the e brake just to see if it's conicidence or not... when I finally find the problem I'll let you know. This is driving me nuts!!!

surfintazz 06-12-2011 10:11 AM

tried the e brake... it worked!! For a minute!! Then it stopped again. ARRRRRG!

chris0001 06-17-2011 08:36 PM

Quote:

Originally Posted by surfintazz (Post 545865)
tried the e brake... it worked!! For a minute!! Then it stopped again. ARRRRRG!


I was having a similar problem, found that my conector to the resistor was loose. Made sure there was a good conection and no more issues so far.... Thanks to topics like this, it gives you other places to look ,(instead of looking for your wallet at the garage...LOL).


All times are GMT -4. The time now is 03:59 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger