DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Custom Dodge Ram Performance Mods - Engine - 4.7 Liter V8 (http://www.ramforumz.com/forumdisplay.php?f=13)
-   -   Some 4.7 questions (http://www.ramforumz.com/showthread.php?t=65887)

HoltFF1074 11-08-2010 10:46 PM

Some 4.7 questions
 
Hey guys,my wifes 2000 Durango which has the 4.7 eng seems to be having a problem with the cooling system. Constant loss of coolant for starters and while i need to trace this problem out,i'm lost as to the location of the thermostat. Is it on the bottom of the engine? I'm suspecting the loss of water may be the waterpump,though i can't be sure. Any help would be appreciated and especially if anyone has any schematics of the 4.7 until i get a manuel for this thing.Thanks,DeWayne

RootBeer 11-08-2010 10:50 PM

Normally you can find the thermostat by following the top radiator hose back to the motor.

RamItAll 11-13-2010 03:29 AM

i have this problem now. posibilities, bad head gasket, bad head, check your thermostat yeah. check all your hoses. also make sure if there is a leak its not hitting the exhaust and disappearing. does your exhaust smoke alot? smell burning anti-freeze?

05atlanticblue 11-13-2010 04:24 AM

Quote:

Originally Posted by RootBeer (Post 354184)
Normally you can find the thermostat by following the top radiator hose back to the motor.

bottom hose on the 4.7...


All times are GMT -4. The time now is 04:13 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger