DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.7L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=185)
-   -   Loud clicking @ 20-30mph "no-load" coast (http://www.ramforumz.com/showthread.php?t=66718)

REDRAMMER 11-19-2010 11:19 PM

Loud clicking @ 20-30mph "no-load" coast
 
Hello All, I think I have a unique situation with my '08 1500 Quad Cab HEMI of which I hadn't found on previous threads. Apparently I am having a loud clicking (NOT the perverbial HEMI tick) under the truck when I am coasting at 20-30 mph. Particularly or more to the point. . .I excel to speed (25-30mph) after turning onto a residential street. I then let off the excelerator to a no-load coast. Loud clicking begins. I drop the automatic tranny down to "2" and the clicking goes away. At "D" coast speed I am at roughly 900-1000rpm, at "2" she goes to about 1600-1700rpm. I am thinking tranny or exhaust. Has anyone had or heard of this problem? Any suggestions or input would be greatly appreciated.

RamTech 11-20-2010 02:41 PM

Pull your drive shafts and check the u-joints for binding or any other signs of the bearings in the caps going bad.

REDRAMMER 11-20-2010 05:33 PM

Thanks RamTech, You the MAN!! Sounds like if anyone would would know these things. . .you would. I recently bought my baby at the USED lot at a Suzuki dealership and wanted to walk in there with at least a suggestion of what it may be considering these guys are probably more familiar with the aforementioned brand. The work will be done under their usual 3mos/3000mi "Certified Used Vehicle" warranty. Thanks again RAMTech.

RamTech 11-20-2010 05:34 PM

Let us know how it turns out.

REDRAMMER 02-17-2013 01:12 AM

Finally back!
 
Well . . .I am finally back. Sorry I have not been here lately. Been busy with life but its been good so far. Anyway, I took my truck to a local Dodge dealer instead of the "other dealer" I bought from. Reasoning told me they would know better than the other guy. The initial diagnosis was the transmission cylinoid was bad making the ratcheting noise. So they practically rebuilt the lower half of the tranny with new fluids, filter and cylinoid, etc. Guess what? After a $100 deductible later, STILL CLICKING at "no load" coast. Took her back and they did a closer look. The culprit wound up being a loose retainer/ tensioner for the chain than engages the MDS (multi displacement system-the system that shuts down 4 cylinders under low loads on the newer HEMIs). So, they practically had to rebuild the entire front end of the engine to replace that thing considering it is mounted behind the water pump and in front of and driven from the engine crank. Needless to say, the warranty covered this also with my expenses being just for fluids. The dealer ate the copay. In summary: I got a lower tranny rebuild w/ new cylinoid, filter and fluids. A rebuild of the front end of the HEMI. Total cost: $1954. My cost: $100 copay + $94 for fluids. Dealer cost: $100 copay for their misdiagnosis. Warranty covered the balance. I bought the extended warranty 2 mos. prior for $1400. I am a BIG fan of those warranties now.


All times are GMT -4. The time now is 08:53 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger