DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Heating & Cooling (http://www.ramforumz.com/forumdisplay.php?f=177)
-   -   Another heat problem (http://www.ramforumz.com/showthread.php?t=68024)

maddface 12-06-2010 08:20 PM

Another heat problem
 
98 ram 5.9 is blowing warm to cool. Top rad hose is hot, both core hoses are hot, bottom rad hose is cold. That mean tstat is stuck closed? Just replaced tstat with engine swap along with waterpump. Tried burping today. Added a few oz of fluid. Am i right about tstat stuck closed?

Oh, and also the seems like its running to cool. Temp gauge is at about 150 to 180 tops

B and B LANDSCAPES 12-06-2010 11:09 PM

mine os currently doing the same exactly to the tee.... replaced motor did water pump and thermo, runs little on the cool side hoses about the same.... but i know i have heater core issues....

Dtimekw 12-07-2010 07:13 PM

Sounds stuck closed to me. How long did you wait before you starting checking the hoses? Your temp guage should have gone way above normal (shut it off before it does). Once you see it go a little beyond it's normal reading, that's a sure indicator of a partial or total stuck t-stat.

RootBeer 12-07-2010 07:30 PM

With both core hoses being hot, its definitely not the heater core. Could be one of the doors is not working though and that's why you're not getting heat in the cab. Engine temp on the other hand should be HOT if the t-stat is stuck closed.


All times are GMT -4. The time now is 03:30 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger