DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   2010 Dodge Ram Forum (http://www.ramforumz.com/forumdisplay.php?f=79)
-   -   Exhaust smell (http://www.ramforumz.com/showthread.php?t=68039)

joeydm 12-06-2010 11:47 PM

Exhaust smell
 
Hi everyone. I have a 2010 ram 1500 w/ Hemi. I added the magnaflow exhaust. 18 inch muffler. I have the factory duals/ and resonators still on. I notice sometimes this sulfur smell after I've laid on it down the highway. I could be cruising at 70 and I smell the sulfur smell inside the cab even. I know that with pickups you get a wind turbulence effect in the rear. But should I be smelling it going down the highway even? Has anyone else noticed this too with their aftermarket mufflers? Thank for the input.

Dan 12-07-2010 02:42 AM

Quote:

Originally Posted by joeydm (Post 375897)
Hi everyone. I have a 2010 ram 1500 w/ Hemi. I added the magnaflow exhaust. 18 inch muffler. I have the factory duals/ and resonators still on. I notice sometimes this sulfur smell after I've laid on it down the highway. I could be cruising at 70 and I smell the sulfur smell inside the cab even. I know that with pickups you get a wind turbulence effect in the rear. But should I be smelling it going down the highway even? Has anyone else noticed this too with their aftermarket mufflers? Thank for the input.

how long ago did you put the muffler on? I've heard of new exhausts having a funky smell for a little while after they've been installed- should just be some residue left over from manufacturing that will burn off after a little while (maybe a week or two). You might also want to check, and re-tighten if necessary, any exhaust clamps, just in case.

Juice420 12-07-2010 03:27 AM

^^^What he said^^^

erm 12-07-2010 08:08 AM

I agree with that ^^^^.

westxsrt10 12-07-2010 11:36 AM

Quote:

Originally Posted by joeydm (Post 375897)
Hi everyone. I have a 2010 ram 1500 w/ Hemi. I added the magnaflow exhaust. 18 inch muffler. I have the factory duals/ and resonators still on. I notice sometimes this sulfur smell after I've laid on it down the highway. I could be cruising at 70 and I smell the sulfur smell inside the cab even. I know that with pickups you get a wind turbulence effect in the rear. But should I be smelling it going down the highway even? Has anyone else noticed this too with their aftermarket mufflers? Thank for the input.

How many miles do you have on your truck? The catalytic convertors can smell like that on newer trucks after a hard run.

brc3858 12-07-2010 12:31 PM

I would say that it's probably normal for a new truck...just check make sure nothing is leaking and you should be fine. I know after I bought mine in the spring, the first few times I hooked it up to pull the boat it would smell. I actually pulled over one time it was so bad but couldn't find anything leaking, just all the burnt tags on the exhaust and engine block. After the third time or so it finally went away. I will say that even with 12000 miles on it if I really get on it I will still notice a slight buring smell just for a second. Just my .02 hope it helps.

2010 HEMI SPORT 12-07-2010 07:07 PM

for some reason my smokes when its parked... i but a flowmaster on it the first week i got it in july, and it still smokes when i turn her on... and now its not from it being cold outside, its hardly ever cold her in houston... well except for now

joeydm 12-08-2010 01:28 AM

I've had my truck since July. I have just over 5,000 miles on it. Exhaust is about 3-4 months old. I guess having that big stock muffler might defuse the smell and the new muffler lets it escape being its more free flowing.


All times are GMT -4. The time now is 02:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger