DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Heating & Cooling (http://www.ramforumz.com/forumdisplay.php?f=177)
-   -   could use some help (http://www.ramforumz.com/showthread.php?t=68658)

Boom8301 12-15-2010 12:38 PM

could use some help
 
i got a 97 ram 1500 sport. up until two weeks ago heat worked great. i tried topping off the radiator. the heater core hoses are both hot. i dont over heat. i have a little heat when sitting and more when i give gas what could possibly be the problem some insight would do wonders thanks...

tuc0007 12-15-2010 01:10 PM

no heat
 
I to have the same problem. what i.v done so far is flushed the rad and the core but still the same . I also put some CLR in the rad to see if this would unglog any thing. But to this date still no heat.

The more people i talk to this is a problem with the dodge they have the in let for the core at the top and the gunk keeps building up and cutting off the core usage.

audiophile 12-15-2010 03:09 PM

Does the a/c work okay? Can you hear the air doors moving when you switch between hot and cold? There could be a vacuum problem or bad switch. If all of that is working then most likely it is in the heater core. Replacing that is a pain (see my other post in this thread). But I would start with a good flush of the system.

Tornado39647 01-03-2011 06:26 PM

What temp is the truck running at when you are driving it? Could have a stuck thermostat in the open position and with the water at full flow it will not get very hot. Just check to see that the truck is still running at normal temp and check the doors for operation like Audiophile stated.


All times are GMT -4. The time now is 11:15 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger