DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Electrical (http://www.ramforumz.com/forumdisplay.php?f=199)
-   -   Radio locked display and cant shut off or reboot! (http://www.ramforumz.com/showthread.php?t=69046)

Walkj60 12-20-2010 04:14 PM

Radio locked display and cant shut off or reboot!
 
I have a 2009 Dodge Ram 1500 Laramie. The radio just "hung" while I was talkiing on the phone through the Blue tooth feature. It is still hung now and wont react to any buttons I push. I turned off the engine and removed the key fob from the ingintion and opened a door to turn off anything that runs for a short time. But, the radio is still "hung" and the display is on and won't shut off. I'm concerned it will run down the battery if I don't do something about it.

Has anyone had a similar instance? Does anyone know how to "reboot" the system, like when you restart a computer?

Thanks for any help anyone can lend.

I am editing this post because after checking it again the radio seems to be fine now. But something else that is diferent than normal. Once it is started using the remote start feature, it shuts on as soon as the key fob is inserted into the dash.

Thoughts anyone?

Thanks.

UN4GTBL 12-20-2010 04:22 PM

Pull the radio fuse?

blue09 12-20-2010 04:26 PM

i have trouble with my radio often. sometimes when i start the truck it will not turn on, the only thing it will do is eject a disc or load one. I have to unhook the negative battery cable for a few seconds, then start up the truck and everything works again. On the plus side it also resets your fuel computer and your gas mileage is much better. Try it and i hope it helps you.

GTyankee 12-20-2010 06:25 PM

If i remember correctly, there is a fix for those radio problems, i believe it was a TSB (technical service bulletin), about it.
Just tell your dealership about it & they should get you the updated version software
*Has lock up bug for CAN C vehicles (unknown at time of release)
No new features however bug fixes include:
Muting of VES 2
VES browsing
New AAC decoder improving reliability
Juke Box Random mode behavior
Phone display screen behavior
Graphics if USB removed during copy
Voice Recognition interaction with Steering Wheel Controls
FF/FW graphics in HDD menu
Added progress bar to USB copy
Update EQs for non amplified system sound performance
Gracenote August 2006
Fix for CAN C vehicle lock up bug on Ignition on

Walkj60 12-20-2010 06:38 PM

Thanks all for your ideas! I appreciate your quick responses.:smileup:

RansRAM 12-20-2010 06:49 PM

GTYankee is right on, I had the Mygig in a 2009 300 and it was locking up as you have described. I'm assuming you have the mygig unit. The fix was a software update that I was able to download and put onto a DVD. The dealer would also be able to do this. Good luck and let us know how you make out.

gerbie28 12-20-2010 08:52 PM

Its happened to me on many ocassions where it would just freeze and didnt shut off i went to the fuse box and pulled the fuse and re-installed the fuse and bingo its worked again

Walkj60 12-28-2010 04:20 PM

Little update, since the problem occur a few days back its been working as normal. My dealer ordered a CD to update the radio but it ended up being the one for the raadio without Nav and touch screen? So they told me they will make a few calls, but if its easy to download from the internet I should be able to burn it to a disc. I just need to figure out where to download it from. Thanks again from all the help everyone!

Quiet Lunatic 01-02-2011 11:25 PM

I have a problem with my Radio/CD player...the face won't come down unless you push the open/close button 10 times and when it does come down and I insert a CD it won't recgonize them. I have an appt tomorrow with the dealership. Not sure if you're having that problem or not.

Walkj60 01-03-2011 12:29 PM

No, I havent had a problem with the face opening/closing.

Since my last post I did download an update, burned to a CD and updated radio myself as a few folks here mentioned. I'm not sure if I'll really ever know if the update helped my problem since it only happened once, but I'll figure it did if it never messes up again.

I also downloaded a "Gracenotes" update (which takes a DVD disk because its so large), and I plan to update it later today. I'm told its to update the database, and that it provides information for song titles that may be missing, and maybe other info, to songs copied to the hard drive.

My radio is the MyGig RER model. The link where I got the downloads,in case anyone needs it, is below.

http://mofv.com/mygig/

I hope this inforamtion helps others as you folks have helped me. Thanks again to you all! :smileup:


All times are GMT -4. The time now is 10:11 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger