DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Heating & Cooling (http://www.ramforumz.com/forumdisplay.php?f=177)
-   -   dumb heater question (http://www.ramforumz.com/showthread.php?t=73301)

V10Ram2500 02-02-2011 11:26 PM

dumb heater question
 
I just recently purchased a 95 Dodge Ram 2500 v10. Ac works perfect, air flow is constant and strong. Heater just doesnt work at all, when the truck is warmed up it sits around 200 degrees and the hoses are hot to the touch just no heat at all no matter if set to defrost vents or floor. No leaking on the passenger floorboard. Would it be that my heater core is just out or the heater control valve? Thx in advance to any help.

RamTech 02-03-2011 09:25 AM

Could be the temp door in the HVAC system but that's pretty unlikely. Have you verified the coolant level? It's possible that the core is restricted and not allowing heat transfer.

V10Ram2500 02-03-2011 02:46 PM

Quote:

Originally Posted by RamTech (Post 432255)
Could be the temp door in the HVAC system but that's pretty unlikely. Have you verified the coolant level? It's possible that the core is restricted and not allowing heat transfer.


I verified the coolant level. Today I put the heater on and moved it from floor to vents to defrost and it wouldnt blow any air on the floor mode but even then does that have anything to do with the it blowing hot air?

GTyankee 02-03-2011 02:57 PM

you can get an better idea of what may be wrong by looking at
http://www.heatertreater.net/Dodge%20Product%20Page.htm

there are YouTube videos for the '02 - '08 models, but, the systems have not changed too much in the last 20 years

V10Ram2500 02-03-2011 04:16 PM

Thanks for the info. I went outside just a few minutes ago to install a radio and speakers and had the truck running. When it got up to its regular temp of around 200, after like 30 min at idle lol, i grabbed the upper radiator hose, it was warm, i assume hot cuz my hands were freezing, but both heater hoses didnt feel warm at all. Does this mean a clog?

RamTech 02-03-2011 04:28 PM

Quote:

Originally Posted by V10Ram2500 (Post 432525)
Thanks for the info. I went outside just a few minutes ago to install a radio and speakers and had the truck running. When it got up to its regular temp of around 200, after like 30 min at idle lol, i grabbed the upper radiator hose, it was warm, i assume hot cuz my hands were freezing, but both heater hoses didnt feel warm at all. Does this mean a clog?

That or a water pump problem.

GTyankee 02-03-2011 04:42 PM

good video about clearing a heater core blockage
http://www.youtube.com/watch?v=dcL_0...eature=channel

V10Ram2500 02-03-2011 05:02 PM

Quote:

Originally Posted by RamTech (Post 432530)
That or a water pump problem.

If the water pump was bad, wouldnt the vehicle run hot or overheat? Or it could still partially work?

Quote:

Originally Posted by GTyankee (Post 432540)
good video about clearing a heater core blockage
http://www.youtube.com/watch?v=dcL_0...eature=channel

Good video, Thank you for posting it.

DJ7211 02-06-2011 10:30 AM

No Heat
 
V10,
I would try back flushing the radiator and heater core as it sounds like the system (is clogged) is not circulating the coolant. Also you may want to install a new thermostat as long as you have the system drained and flushed.
DJ

V10Ram2500 02-07-2011 04:33 PM

Quote:

Originally Posted by DJ7211 (Post 435269)
V10,
I would try back flushing the radiator and heater core as it sounds like the system (is clogged) is not circulating the coolant. Also you may want to install a new thermostat as long as you have the system drained and flushed.
DJ

Back flushing like in the video that was posted or just like a regular flush? And I def will be adding a new thermostat and probably new radiator as the one in it now leaks. Thx for the help.


All times are GMT -4. The time now is 07:14 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger