DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   2010 Dodge Ram Forum (http://www.ramforumz.com/forumdisplay.php?f=79)
-   -   Bought a new truck a few months back and nothing but problems at first! (http://www.ramforumz.com/showthread.php?t=73352)

heffs03mach1 02-03-2011 07:19 PM

Bought a new truck a few months back and nothing but problems at first!
 
Bought my truck a few months back and was wondering who else had a crap ton of things wrong from the factory / poor customer service. I must say the whole experience with the Dodge dealer in Austin Tx. was the worst. I live a ways away up in Belton which is about 70 miles away and didnt really want to be dealing with the whole situation but there I was dealing with it all. First off I noticed the drivers side fender and hood werent lining up correctly. The hood was higher then the fender. Next thing was the dvd system and the nav werent working correctly. The tpms sensors still arent working correctly. Mostly the whole thing was that the Austin dealer was too far and they wanted me too do all the driving back and forth from the dealer to my house and sit and wait all day while the truck was fixed. There is too much to type about the whole experience but it sucked to say the least. This lasted for about 1 1/2 months then i finally gave up on them. The last straw was when they ordered the new head unit and called to say it was in and i told them i couldnt make it down there cuz the truck was in arkansas with family but in about a month we would have it back please hold onto said unit till then. well a month goes by i'm in iraq and my wife takes the truck down there to get the new head unit installed, after she called and made an appt and verified they had it. long story short she went down there and they had sent it back and wasted our time and gas money and didnt give two shits about the situation. So we have since quit going there and have moved onto another dealership but still am having problems with the tpms sensors saying there is faults but resetting after 15 miles only to trip again shortly.
We had the new wheels put on with the factory tpms sensors and have been back to the discount tire 3 times with wheels and tires off the truck and pulled apart to see what the problem is. Everything is secure as far as tpms and the techs have no idea. so now what to do. This is in the rear and goes back and forth between the left and right wheels only. Any ideas or should i just start a thread about the tpms sensors somewhere to figure this out.

Pull Ya 02-03-2011 07:32 PM

What dealership in Austin? I've had good luck with Benny Boyd in Bastrop. Ask for Aaron(service writer) and tell him I sent you. Ask for "John" to do the work. He is the best mechanic there. Good luck with getting your problem(s) solved.
Jay

heffs03mach1 02-03-2011 07:52 PM

It was Southpoint Dodge and it was nothing but a headache trying to get things done right the first time. When I bought the truck they agreed to tint the windows and also detail the truck the next day. Three weeks later and all the problems later still nothing done but the hood lined back up with the fender and the truck returned to me filthy as the day i got it. When i said detailed i meant detailed not washed and here you go. There was a sticker on the side of the truck at some point that when washed the outline stood out so i wanted that fixed too. at one point the dealership agreed to give me a loaner and come pick up and drop the truck off which was fine with me except i needed it on the weekends for the lake and trips. well eventually they detailed the truck as agreed but never tinted the windows because i wanted 20% like all my vehicles and the place they went to refused to do a dealer job out of state specs so i had to eat that one and do it myself. There was a few weeks i was of half a mind to return the truck and go buy a ford because i was getting pissed and ready to start breaking some heads. The wife didnt understand why i was so mad after dealing with them tell she got screwed over on the trip down there for the head unit lol.

heffs03mach1 02-03-2011 07:56 PM

On the tpms sensors i dont think they will be covered because i changed the wheels out and had someone else do the work instead of dodge. ill let you guess why but it involved a bill of something like $600 from dodge for a wheel and tire change with mounting and balancing vs. a $180 from discount tire etc. Dodge was saying something about i had to have new tpms sensors etc etc and there was no way to use the old ones but discount tire said they did it all the time so yah.

Pull Ya 02-03-2011 08:23 PM

Round and round we go! LOL If you have any warranty problems I'd still try Benny Boyd service dept. They treat me pretty good and I didn't even buy the truck from them because some of their sales staff have a problems with the truth and the way they treat customers.
Jay

HoustonHemi 02-03-2011 08:48 PM

Belton and Bastrop are quite a ways apart,,,,

Any good Dealer feedback/recommendations from any members in the Waco area?

I'm in Houston,,, Right between 2 major dealers,,, the 'far' one is 12 miles,,,

heffs03mach1 02-03-2011 09:06 PM

I ended up going into killeen to dodge country and nothing but great service surprisingly.

Toms Blue Ram 1500 02-03-2011 09:12 PM

I'd try another dealer . Some dealers just don't care . Gives the Dodge name a bad rep .

Pull Ya 02-03-2011 09:33 PM

I bought my truck from Allen Samuels in Waco. Good sales dept and the parts manager is a good personal friend but I haven't had any experience with their service dept.
Jay
PS--With the number of crappy dealers around I don't think I'd mind driving a few extra miles to find a good one--IMHO!


All times are GMT -4. The time now is 10:31 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger