DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.9L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=173)
-   -   I got an iffy problem... (http://www.ramforumz.com/showthread.php?t=74578)

B Rue48 02-16-2011 08:13 PM

I got an iffy problem...
 
My truck idles funny. It'll idle for like a min or two then starts shaking and sounding like its choking on something. Today I took a note that it sounds like it is being fuel starved. I started it and popped the hood, and just listened. When it started to act up, it sounded like it was sucking in more air as it got worse. The kicker to this is that when its dropped in gear it runs perfectly fine. Any ideas? All feedback is greatly appreciated. Thanks!!

98redbull2 02-17-2011 09:21 AM

maybe your fuel pressure is dropping at idle, i read a thread on here where a guys fuel pump was going bad and was at 4 psi all the time. i thaught when a fuel pump was bad it just didnt run at all but i was wrong. maybe have your fuel rail pressure checked out, thats one canditate. i think its supposed to be around 33 psi, something like that.

B Rue48 02-17-2011 07:03 PM

Thanks man I'll check that out!

RamTech 02-17-2011 08:23 PM

Running at 4 psi? Sure, if it's a carbuerated engine. Fuel pressure should be 44-59 psi.

98redbull2 02-18-2011 08:44 AM

Quote:

Originally Posted by RamTech (Post 447076)
Running at 4 psi? Sure, if it's a carbuerated engine. Fuel pressure should be 44-59 psi.

o damn i was still a little low lol yea idk the guy said his truck was runnin on 4 psi, it was knockin and pingin under load and the check engine light would flash so that would prolly do er lol.

livinlifes2short 02-24-2011 12:50 AM

Hey guys new here and did a search found our post, I am having the same problem, i just replaced my fuel pump a month ago and this was happening before and after, sounds like a have a dang turbo makes a loud sucking noise from the throttle body area and idle drops some times it will pick back up or I have to give it gas a few times for it to fix its self, or like he said put it in gear. Makes me think that its the IAC valve is there any way to test this without a computer? Or any other good thoughts?? Thanks 97 5.9 ram sport

magnumv8 02-26-2011 10:29 AM

Quote:

Originally Posted by livinlifes2short (Post 452948)
Hey guys new here and did a search found our post, I am having the same problem, i just replaced my fuel pump a month ago and this was happening before and after, sounds like a have a dang turbo makes a loud sucking noise from the throttle body area and idle drops some times it will pick back up or I have to give it gas a few times for it to fix its self, or like he said put it in gear. Makes me think that its the IAC valve is there any way to test this without a computer? Or any other good thoughts?? Thanks 97 5.9 ram sport

I am having the exact problem. it started sucking air bad after my battery died and i replaced it with a new one. started running rough and wanted to die out in park or nuetral. after i shut it down and turn it back on it ran fine for a few days, now it will not start and just cranks, and i can smell fuel afterwards any help would be very much ppreciated

magnumv8 02-28-2011 02:19 PM

I go out and try to start the truck every morning and it did start for me today. but it started and blew out some smoke and then it idles i would say around 600 to 800 rpm. but there is a tick tick tick tick coming from the left side of my enginge. athe truck has 186000 miles on it but the top end was rebuild. this all started when i took the alternator off and put it back on and replaced the battery. i dont want to drive it like this if it will do more harm.

sdram03 03-04-2011 08:05 PM

Quote:

Originally Posted by livinlifes2short (Post 452948)
Hey guys new here and did a search found our post, I am having the same problem, i just replaced my fuel pump a month ago and this was happening before and after, sounds like a have a dang turbo makes a loud sucking noise from the throttle body area and idle drops some times it will pick back up or I have to give it gas a few times for it to fix its self, or like he said put it in gear. Makes me think that its the IAC valve is there any way to test this without a computer? Or any other good thoughts?? Thanks 97 5.9 ram sport

i was thinking the same thing... IAC. the sucking problem can be the IAC adjusting, letting in more air to adjust the idle. and then when in gear, there's a load on the engine and ecm may have already adjusted with more fuel. if there is too much carbon around the IAC, that can cause issues too. if the AFR requires more air (according to what O2 reading during closed-loop), ecm will try adjust the IAC to fix it. well, too much carbon may not let the proper air get thru and now the IAC, O2, ECM are all fighting to get the engine to run right. oh, and include MAP sensor in there too. i'd remove the IAC and make sure it's nice n clean and the ports associated with it are spotless. i had a plymouth that was PICKY!!!! did a lot of short driving and had to clean the IAC almost every other oil change. otherwise, it would Idle like CRAP. and don't even think about turning on the A/C. the extra load was enough to put it over the edge and kill the engine.

Justin69 05-12-2013 10:07 PM

My 99 douse the same thing can't figure it out if u figure it out email me justinhillyer@gmail.com


All times are GMT -4. The time now is 08:17 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger