DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Dodge Ram General Discussion (http://www.ramforumz.com/forumdisplay.php?f=10)
-   -   Installed cab lights now no parking lights on right side (http://www.ramforumz.com/showthread.php?t=74655)

MikeEB76 02-17-2011 01:01 PM

Installed cab lights now no parking lights on right side
 
So I installed a set of aftermarket cab lights on a 03 Ram 2500. The install went pretty simple, single power to all 5 lights ran to the switch, single ground to all 5 lights ran to the dash mount. Everything works as it should with the cab lights. However, after I finished I noticed the parking lights on the passenger side no longer work. I am not completely certain they were working before, but I think they were. I did the obvious checks I could think of to no avail; ie. bulbs, fuses, taillight circuit board, dash switch.

Any other ideas for things I could check? Part guy at Dodge mentioned they have alot of trucks come back in with a integrated power module go bad that causes irregular light failures. Is there a way to test the module without replacement? Buying a $400+ dollar part and hoping for the best gets expensive.


Thanks in advance,
Mike

Toms Blue Ram 1500 02-18-2011 10:26 PM

It sounds like it could be the module . Check and see if you have power to any of the bulbs . Also check all fuses too . Stop by the newbie section also . If you could go to the top of the page to the User Cp and complete your profile that would be great . Helps us see what you have when your posting a question or comment .


All times are GMT -4. The time now is 03:27 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger