DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.2L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=172)
-   -   1997 1500 tranny issue (http://www.ramforumz.com/showthread.php?t=76444)

dgramo 03-08-2011 11:09 AM

1997 1500 tranny issue
 
I have a 1997 1500 with the 5.2 auto 4wd. Recently the trans started acting up. Was driving it and it would not shift out of gear unless I shifted to neutral and then back into drive. It is also slipping when I start out from a dead stop. More so in reverse than drive.

Anyone have experience with this type of issue? I really miss driving my truck and I sure hope I don't need a rebuild.

frealz13 03-08-2011 09:49 PM

tranny
 
mine sticks in second it doesnt slip though.check your fluid ? im gonna change the govenor pressure solenoid and sensor and put a new filter in mine. ill let you know how it goes good luck with yours. hopefully its something stupid.

tuc0007 05-06-2011 01:58 PM

Wtf
 
did you do a trany flush or just change the fluid?
is the fluid right up?

nix-chic 03-15-2012 04:52 PM

I have a 98 1500 and this will be the 3rd time someone is in the tranny, can anyone explain what the piston is and how can you break it all to pieces?

tuc0007 03-15-2012 10:30 PM

a piston is a bout the strock why would you


All times are GMT -4. The time now is 05:37 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger