DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Electrical (http://www.ramforumz.com/forumdisplay.php?f=199)
-   -   Trailer turn signal issue (http://www.ramforumz.com/showthread.php?t=78449)

rjr1214 03-28-2011 05:46 PM

Trailer turn signal issue
 
I have a problem with the trailer wiring coming from my truck. When I'm plugged in I get no left turn signal at the trailer. I checked the fuse, and it is ok. I used a multimeter to check the 7-pin round plug on the truck and it is not getting any power to the left turn. I checked the wires coming out of the trailer harness and leading to the front of the truck and could see no obvious failures there, but the wiring bundle runs along the drivers side frame where it meets up with some other wire bundles along the way and then up into the left fender where I can no longer see it...assuming it runs into the bottom of the fuse box there. Any ideas, experience with this type of issue?

RamTech 03-28-2011 05:51 PM

Here's a diagram that may help your diagnosis.

https://w05.dealerconnect.chrysler.c...S/81584dc0.gif

rjr1214 03-28-2011 07:16 PM

Do you know what color wire should be feeding the left turn signal for the trailer adapter? this would help me to follow it.

RamTech 03-28-2011 08:09 PM

The yellow wire is for the left turn/stop lamp. Circuit 673 in the diagram above.

rjr1214 03-28-2011 08:50 PM

So after spending way too much time jerking around under the truck and fixing some wires/splices that were bad, I made a breakthrough. After repeatedly checking fuses I turned on my right turn signal (this one works on the trailer) and listened to the relay in the IPM (fuse box) and then turned the left signal and listened to that relay... has a funny sounding "click - donk" rather than "click - click." After doing a google search for '2004 dodge ram trailer tow left turn relay' I have verified that these trucks are actually pieces of crap and the relay is integrated into IPM, thus requiring replacement of a several hundred dollar part that I can't locate... not even on crapslerpartcenter. Now this Dodge is turning into a Chevy and I knew I should have bought a Titan, but thought the diesel would be better.

Arctic Owl 03-29-2011 12:45 PM

Sorry to highjack this thread, but;
Hey Ramtech. Do you know were the power source is for the rear 12v Power Outlet in a 2010 3500 Laramie? I have checked all the fuses under the hood & they are OK. I do not have any power at the plugin. Is there another fuse system inside the truck? Yes I have made sure the key is on before checking.

Reg

RamTech 03-29-2011 12:54 PM

Power comes from the TIPM under the hood. Since it's under warranty, let the dealer handle the problem.

Arctic Owl 03-29-2011 01:01 PM

Thanks for the quick reply Ramtech. Guess it may mean replacement of a part or just a reflash?

Reg

RamTech 03-29-2011 01:09 PM

TIPM problems usually require replacement of the module itself.


All times are GMT -4. The time now is 08:30 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger