DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.2L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=172)
-   -   Darn thing won't start --> clicking noise under dash (http://www.ramforumz.com/showthread.php?t=81539)

david05111 05-01-2011 03:22 AM

Darn thing won't start --> clicking noise under dash
 
Info on truck:
1995 Ram 1500 318
Located in Florida

Hey Gents-

I've run into a problem with my truck which I can't seem to figure out. It won't start.

I put the truck in the garage for the winter and starte it a few times. About a month ago, I took it out for a spin, but only after I charged the battery up. I figured this was fairly typical because it had sat for so long.

The other day, I went to start it and it was deader than dead, absolutely nothing. Put it on the charger, barely got anything. Charger said the battery was bad. Ok, no big deal. I bought a diehard tonight and put it in. I cleaned the connections and made sure everything was tight. So, I confirmed it had power and got in to start it.

First off, there is a rapidly blinking red light next to the OD button, which I assume is a security system. I bought the truck used so I only have one key, which isn't anything but a metal piece cut to start it (no chip or anything, but I don't know if a 95 even had a engine disabling system in it). Not only is it doing that, but there is an odd ticking noise coming from underneath the dash, just below and to the right of the steering column. It sounds like a turn signal, but is a separate sound.

When I went to start it, I confirmed on the dash that it was displaying plenty of voltage, above the halfway mark which should have been more than adequate. So I turned the key and nothing; the dash lights went out like there was a draw in power, but no cranking or even clicking; nothing. I released the key and let it go back to center and everything came back on; the clicking under the dash was doing it's thing the whole time.

I checked the cables again and confirmed the battery voltage. The headlights work, stereo works, AC, radio...but no cranking at all.

What the heck is going on?? I wen back and looked a few minutes later and whatever that clicking is, which is almost constant whether or nt the key is in the ignition and the blinking light are putting a serious drain on the battery.

I hooked the battery charger up to engine start; still nothing. Did the security system in 95s disable the engine? What is that clicking noise? So annoying...I was supposed to use this thing for the first time in a while tomorrow and it doesn't work!

RedRam10 05-01-2011 08:32 AM

Sounds like a bad relay of some type, that clicking is a sign of a relay trying to close. How mechanical are you? Can you find it while listening under the dash?


I see you've been here a while but never had an introduction. How about using the link in my SIG to jump on the Newbie Checkin and introduce yourself and posting a few photos of your truck? :Hey:

CajunDodge 05-01-2011 08:41 AM

I was thinking relay, too and at first was thinking starter relay but after reading the whole post, sounds like something different.

- Cajun

david05111 05-01-2011 08:48 PM

UPDATE: I took the dash apart to find the source of the clicking. And to my annoyance, I found a present waiting for me. This truck apparently had an aftermarket alarm installed or something. The box that is clicking is from a "CODE Alarm Pro 750.". So I guess this damn box is disabling my engine; the question is, WTF do I do now?


All times are GMT -4. The time now is 04:35 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger