DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Great Lakes (http://www.ramforumz.com/forumdisplay.php?f=97)
-   -   HELP Transmission (http://www.ramforumz.com/showthread.php?t=86204)

Coxy360 07-01-2011 11:53 PM

HELP Transmission
 
Bought my 97' 1500 Sport 360ci from a buddy of mine had 185,000 miles mostly highway.... i bought it in march which was still cold in indiana and i noticed that when i started my truck even after letting it warm up for maybe 5 minutes i would start down the road and it would be pushin 4500 rpms and not shifting out of first i would have to pull over and stop and let it idle in park or neutral to get it to shift fine i asked the guy who i bought it off and he said he had it rebuilt and when it was rebuilt some sort of re-back (not correct name) valve was taken out which doesn't alow the tranny fluid to circulate or stay in the tranny when the truck is off i know dodges are notorious for the transmissions but i love this truck and need to keep it on the road any help or suggestions please let me know! thanks

ramvan2500 07-03-2011 03:33 PM

Quote:

Originally Posted by Coxy360 (Post 560370)
Bought my 97' 1500 Sport 360ci from a buddy of mine had 185,000 miles mostly highway.... i bought it in march which was still cold in indiana and i noticed that when i started my truck even after letting it warm up for maybe 5 minutes i would start down the road and it would be pushin 4500 rpms and not shifting out of first i would have to pull over and stop and let it idle in park or neutral to get it to shift fine i asked the guy who i bought it off and he said he had it rebuilt and when it was rebuilt some sort of re-back (not correct name) valve was taken out which doesn't alow the tranny fluid to circulate or stay in the tranny when the truck is off i know dodges are notorious for the transmissions but i love this truck and need to keep it on the road any help or suggestions please let me know! thanks

Dodge transmissions have problems because people don't know how to properly fix or rebuild stuff and they don't know how to take care of the transmission. Anyways their is also a check ball that keeps the transmission fluid circulating in only one position much like a diode keeps current flowing in one way. Anyways, I think I would have the bands adjusted for the sake of it it would only make sense to do this because it was rebuilt and usually during a rebuild they don't use a precise torque wrench when it comes to adjusting because you get use to using one wrench when assembling then you accidentally use that same wrench to do operations that must be done precisely. Well all that out of the way, you should first look into checking the throttle position sensor, the TPS sits on the throttle body and it sends a signal to the S.B.E.C, the S.B.E.C calculates the position of the throttle so it knows when to tell the transmission to shift, usually when the TPS dies you can have weird idle problems, you can certainly have weird shifting problems (most common).

Here is a quicky way to test the TPS, do it with a digital volt meter and do it very slowly because the TPS is basically like a Rhaeostat and it develops blind spots, oh anyways if their is a issue with idling it's either the TPS or MAP sensor because the MAP and TPS work together to control the IAC. But anyways here are the directions.:

This is for adjustment but it will give you and idea for how to test it. Basically to test just check the signal output voltage and then very slowly put the foot on the pedal and press down and the voltage should increase. If the voltage decreases or not voltage registers or whatever then it's a pad TPS. Be sure to test with the key in the ignition with the key pointed to the ON position, DON'T START THE VEHICLE, Not required.

TPS Adjustment

The throttle position sensor, shift lever, and throttle valve cable are critical to proper operation of the transmission. If one or more of these are out of adjustment or if the TPS is noisy, shifting will be erratic. Before performing any adjustments, check the transmission fluid level and sniff the fluid. Do not make any adjustments until the fluid level is correct, and burned fluid has been replaced.

The service manual says to adjust for 0.8-1.2V at idle. On many trucks, this voltage is too low, resulting in TCC chatter at moderate throttle loads. The TPS is not officially adjustable but the mounting holes are slotted and the body can be rotated slightly. Adjustment is relatively easy, and requires only a digital voltmeter and a few hand tools. A little adjustment goes a long way...

TPS wire color code:

Black = ground
Orange/dark blue stripe (center pin) = signal
Purple/white stripe = 5V power

Testing and adjusting the TPS:

1. With the key "OFF", unplug the connector from the TPS.

2. Turn the key "on" and insert DVM probes into the connector to reach the connector pins. Short pieces of wire or paper clips can be used to extend the DVM probes for reaching into the connectors.

3. Read from the purple wire to the black wire (these should be the outside pins). Power should be 5V with the key "on".

4. Turn the key "off" and plug the connector back onto the TPS

5. Insert the leads from the digital volt meter into the back of the TPS connector. The DVM negative probe goes into the back of the connector cavity with the black wire. The positive DVM probe goes into the back of the connector cavity with the orange signal wire.

NOTE: Push the probes into the rear of the connector until the probe tips reach the metal connector pins.

6. Loosen the TPS mounting screws

7. With the engine off and key on: Adjust the TPS position for 1.2 to 1.5V on the signal wire with the throttle at the idle position - more voltage makes more TC clutch pressure, too much will set a fault code. Often, adjusting for 1.4 to 1.5V at idle will cure TC clutch chatter under light load conditions. NOTE: The factory setting is 1.2V max, so proceed carefully.

8. Tighten the TPS screws, slowly open the throttle to the WOT position and then return return to idle. Watch for voltage jumps - the voltage should change smoothly from the idle value to at least 3.5V at WOT (5 volts is all you should be able to get). If the sensor voltage jumps or drops unexpectedly - replace the sensor or try the filter modification below.


Tell me how it goes.


All times are GMT -4. The time now is 07:58 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger