DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   5.9L V8 Specific Topics (http://www.ramforumz.com/forumdisplay.php?f=184)
-   -   My dreadful 4th of July beach trip (http://www.ramforumz.com/showthread.php?t=86794)

Redlongbed 07-10-2011 10:32 AM

My dreadful 4th of July beach trip
 
Last Sunday my girlfriend, my dog and I headed out to Assateague Island in Maryland in my 2002 Ram 1500. I bought a beach pass in May so I could take my truck on the beach. We headed out on the beach and were having a fun day. We decided to leave around 5 pm. I wanted to drive down the beach a little just to cruise on the sand then we were going to leave. As I was driving down the beach my transmission temp light on the dash came on. I knew I had to shut the truck off so I was pulling out of the way of the main part of the beach and the truck shut off. I tried to start it and it was sputtering really bad and barely even running. I checked the oil, trans fluid and coolant and everything was fine. I am no mechanic so I was at a loss. After three different trucks trying to drag me down the beach, one of which, a GMC sierra, royally destroyed his transmission, I decided it was finally time to give in and call a tow. The towing company couldn't get there til nine am the next day so I spent the night and the company came with a pretty sweet old C30 wrecker set up for off road towing. 45 minutes and $400 later my truck was back on pavement. After a day of sitting in a shop they called me and told me it was the ignition coil. Truck runs fine now and the repair was less than the tow bill to get it off the beach! Just thought I would let you guys know. I don't know if this is a common problem, or if this is a part that needs to be replaced or I just got unlucky with a faulty one. Just thought it would be nice to know because I would hate for anyone to be stranded like I was. By far the worst experience of my life.

Scott B 07-10-2011 04:17 PM

which motor do you have? i have a 4.7 and i have 8 individual coil packs, one per plug mounted on top of each one.

erm 07-10-2011 04:30 PM

He's got the 5.9L (360 ci) engine

CajunDodge 07-10-2011 04:33 PM

That seriously sucks but glad it was something like that and not much worse.

- Cajun


All times are GMT -4. The time now is 03:14 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger