DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   Heating & Cooling (http://www.ramforumz.com/forumdisplay.php?f=190)
-   -   No heat, soo cold, please help! (http://www.ramforumz.com/showthread.php?t=94378)

hemipoweredram 10-15-2011 07:38 PM

No heat, soo cold, please help!
 
Tryed search but im in the booneys an on dial up this site loads sloww! I have a 05 ram hemi, My heater isnt working, doesnt blow hot or cold or at all, where should i start?

erm 10-15-2011 09:00 PM

No fan? Check your HVAC system fuse.

RedneckMechanic 10-15-2011 10:57 PM

Start with the fuse as MADDOG suggested. Then the motor. More often than not, if the fuse is good and your not getting any air, it's the motor. Should be under the dash right above the passenger's feet. A fairly easy swap out if I remember correctly... To test, unplug it (it'll be a two wire, twisted harness, black and green wires) and test continuity between the two terminals ON the motor. If your multimeter reads OL, it's shot. Means there's no contact between the brushes and the stator. This is the most common test result. Just to be sure your motor is getting power, with the truck on, not running, and the fan motor switch on full, you should get voltage on the green wire... Hope this helps. Sucks to find this out this time of year...


All times are GMT -4. The time now is 12:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger