DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   2011 Dodge Ram Forum (http://www.ramforumz.com/forumdisplay.php?f=117)
-   -   2011 2500 Ram ABS problems (http://www.ramforumz.com/showthread.php?t=95788)

markfulling 11-04-2011 01:55 PM

2011 2500 Ram ABS problems
 
Started my truck last week and the ABS, BRAKE and ENGINE lights all stayed on. Then I noticed that the info screen said that I needed to service the 4WD system (and then that light came on), next it said that the Trailer brake was disconnected. I looked down and saw that the trailer brake was flashing a "!" and read "CF" on it. Went do drive it down the street and noticed that the speedo and odo weren't working.
I took it to the dealer and they unplugged the ABS module (right behind the battery, next to the firewall) and plugged it back in. Problem fixed.
Service rep: "Well, that fixed your problem. Maybe there was some moisture in there since it got cold last night. Just bring it back if this happens again."
It happened again 2 days later. I called again, took it in again and now they're going to order a new ABS module. I'll update this once the new one is installed.

Truck is about a month old with 1500 miles.

erm 11-04-2011 04:05 PM

Yeah, sometimes the electronics don't survive the burn - in. I've read about this before and it's not limited to the 4th gen trucks, either.

Glad they took care of ya!

markfulling 11-21-2011 11:14 AM

Dealer installed a new ABS module and the problem is gone.


All times are GMT -4. The time now is 07:35 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger