DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Search Forums
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Showing results 1 to 4 of 4
Search took 0.04 seconds.
Search: Posts Made By: Lumpo
Forum: 5.9L V8 Specific Topics 10-15-2009, 07:56 PM
Replies: 9
Views: 7,031
Posted By Lumpo
The 3 plugs that i remember plugging are the...

The 3 plugs that i remember plugging are the Crank, Oil sending unit and the Pickup. Are these the plugs your talking about? Im confident the spark plugs are done correctly but i will check the...
Forum: 5.9L V8 Specific Topics 10-15-2009, 04:57 PM
Replies: 9
Views: 7,031
Posted By Lumpo
Yes i believe the crank sensor is installed...

Yes i believe the crank sensor is installed correctly and i was very careful when intalling it. I also believe that all grounds to the PCM are good. The grounds are good because it started just fine...
Forum: 5.9L V8 Specific Topics 10-15-2009, 03:27 PM
Replies: 9
Views: 7,031
Posted By Lumpo
Already checked all fuses sorry i forgot to...

Already checked all fuses sorry i forgot to mention that.
Forum: 5.9L V8 Specific Topics 10-15-2009, 03:17 PM
Replies: 9
Views: 7,031
Posted By Lumpo
No Spark!

I have a 1998 Dodge Ram 5.9 and i cant figure out why i have no spark. I also cant read the PCM with my scanner for some reason. I have tried a new Crank sensor still no power at coil. How can i...
Showing results 1 to 4 of 4

 
Forum Jump


Advertisement






All times are GMT -4. The time now is 01:48 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors