DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Search Forums
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Showing results 1 to 7 of 7
Search took 0.01 seconds.
Search: Posts Made By: slow4.7
Forum: Kills and More Kills 11-30-2010, 03:32 PM
Replies: 19
Views: 5,714
Posted By slow4.7
this a fast truck!!! i raced him!! lol

this a fast truck!!! i raced him!! lol
Forum: Newbie Checkin! 11-29-2010, 02:30 PM
Replies: 15
Views: 1,476
Posted By slow4.7
Thanx guys.......and no rear axle work..stock...

Thanx guys.......and no rear axle work..stock 3.92 gears.....i have a set of 4.56s waiting on install....possibly in two weeks......... i havent tooken the truck to the 1/4 mile....only eighth mile...
Forum: Kills and More Kills 11-29-2010, 12:09 PM
Replies: 16
Views: 1,660
Posted By slow4.7
my hemi vs 6.0

my hemi vs single cab stepside...6.0 ..longtubes,efan,ls6 intake manifold,cai,3600 stall,pulley.. he needed a retune so we ran before....and now in couple day he will have his rematch

vid was...
Forum: Custom Dodge Ram Performance Mods - Engine - 5.7 HEMI V8 11-29-2010, 12:05 PM
Replies: 25
Views: 2,689
Posted By slow4.7
custom 4 inch pvc intake would be nice....remove...

custom 4 inch pvc intake would be nice....remove cats :D

diablo or superchips if they have them already.....some 17s and drag radial for the track..

and 75 shot of nitrous to keep it safe ...
Forum: Custom Dodge Ram Performance Mods - Engine - 5.9 Liter V8 11-29-2010, 12:03 PM
Replies: 7
Views: 2,088
Posted By slow4.7
i have a 170 motorad t stat and it runs...

i have a 170 motorad t stat and it runs fine...and right now in texas it has been pretty cold..and no issues

might want to replace the thermostat or check it out..might be defective
Forum: 4.7L PowerTech V8 Specific Topics 11-29-2010, 12:01 PM
Replies: 22
Views: 11,800
Posted By slow4.7
i would start on the head gaskets....i had the...

i would start on the head gaskets....i had the same problem a few years back...white smoke coming out...i changed gaskets and worked fine...


although couple weeks later i blew 2 pistons due to...
Forum: Newbie Checkin! 11-29-2010, 11:52 AM
Replies: 15
Views: 1,476
Posted By slow4.7
new hemi herreee

wuts up guys..im from texas...i have a 2004 quad cab ram..originally a 4.7 but swapped a 2007 hemi motor hemi into it...usiing the 4.7 computer and harness.. mopar performance cable tb...and my pcm...
Showing results 1 to 7 of 7

 
Forum Jump


Advertisement






All times are GMT -4. The time now is 06:46 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors