DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Search Forums
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Showing results 1 to 17 of 17
Search took 0.02 seconds.
Search: Posts Made By: crg1987
Forum: Custom Dodge Ram Performance Mods - Engine - 5.9 Liter V8 01-11-2012, 08:55 PM
Replies: 5
Views: 846
Posted By crg1987
My transmission has the TransGo shift kit as well...

My transmission has the TransGo shift kit as well as upgraded clutches. I have mine chipped with a superchips tuner and my redline is at 5400 RPM. It shifts nice and firm at just under that. ...
Forum: Custom Chassis - Drive Line - Suspension - Wheels and Tires - LIFTING - Dodge Ram 4x4, 2x4 11-06-2009, 10:39 PM
Replies: 15
Views: 2,518
Posted By crg1987
The owners manual for my 99 quad cab states that...

The owners manual for my 99 quad cab states that you can put the truck into 4-hi up to 35 miles an hour (i've never done it going that fast cuz i'm afraid to) and that it'll go into 4-lo doing less...
Forum: 5.9L V8 Specific Topics 11-06-2009, 10:22 PM
Replies: 3
Views: 711
Posted By crg1987
Im not burnin any oil. The truck was running...

Im not burnin any oil. The truck was running great until this. I did the motor myself and used a better gasket than what came with the motor cuz my old motor had that problem. I deleted my cat and...
Forum: 5.9L V8 Specific Topics 11-03-2009, 05:56 PM
Replies: 3
Views: 711
Posted By crg1987
So I figured it out. It is a clogged cat. This...

So I figured it out. It is a clogged cat. This kinda sucks since the Cat is less than six months old and since I live in California it costs an arm and a leg for a new one. This is why I'm just...
Forum: 5.9L V8 Specific Topics 11-03-2009, 02:46 PM
Replies: 3
Views: 711
Posted By crg1987
No Power!

Alright so here's the deal. I have a 99 Ram 1500 with the 5.9 Liter in it. It's a brand new motor with less than 8000 miles on it. It has a cold air intake on it and has a superchips flash in it...
Forum: Electrical 05-17-2009, 11:43 PM
Replies: 2
Views: 832
Posted By crg1987
Yep. I got good pressure and spark and...

Yep. I got good pressure and spark and everything...I've been workin on it more and now I think it's timing...This ones kickin my butt...
Forum: Electrical 05-12-2009, 11:13 PM
Replies: 2
Views: 832
Posted By crg1987
Test the ECU?

I have a problem that I've posted in the mechanical section, but I'm thinking its an electrical one. I have a 99 1500 5.9L and it runs like it's not getting enough fuel and its throwin two codes....
Forum: Body & Interior 05-11-2009, 09:11 PM
Replies: 16
Views: 4,660
Posted By crg1987
If all else fails...hit it with a hammer!! The...

If all else fails...hit it with a hammer!! The latch not the door!
Forum: 5.9L V8 Specific Topics 05-11-2009, 05:42 PM
Replies: 5
Views: 584
Posted By crg1987
I agree with chithead, unless your leaking a ton...

I agree with chithead, unless your leaking a ton of oil which I'm sure you would have noticed. The pickup tube for the oil pump could have started to loosen and rotate to where the pump is picking...
Forum: Custom Dodge Ram Performance Mods - Engine - 5.9 Liter V8 05-10-2009, 08:57 PM
Replies: 8
Views: 855
Posted By crg1987
I'm hearing that they are intended more for...

I'm hearing that they are intended more for carberated motors anyway so I'll wait until I get cash I want to burn (which is never...lol) Thanks for the input on the rest!
Forum: Custom Dodge Ram Performance Mods - Engine - 5.9 Liter V8 05-10-2009, 01:20 AM
Replies: 8
Views: 855
Posted By crg1987
TB Spacers?

I've got a 99 1500 4X4 with the 5.9L V8 and I'm wondering if anybody has used a TB spacer that actually works...If one of you all have one that works let me know the brand name and all that good...
Forum: Heating & Cooling 05-08-2009, 06:25 PM
Replies: 5
Views: 935
Posted By crg1987
Sounds like a loose belt that slips when it's...

Sounds like a loose belt that slips when it's under load. Try putting a wrench to your tensioner and give it a nice tuge to make sure the belt is snug.
Forum: Electrical 05-08-2009, 06:20 PM
Replies: 3
Views: 480
Posted By crg1987
A little update on my problem... Turns out i got...

A little update on my problem... Turns out i got two DTCs. One being the MAP sensor and the other being the throttle position sensor. The throttle position sensor wasn't sending out the right...
Forum: 5.2L V8 Specific Topics 05-07-2009, 05:03 PM
Replies: 8
Views: 1,402
Posted By crg1987
Make sure the spark plug wires are in the right...

Make sure the spark plug wires are in the right spots. I had two of mine swapped and couldn't figure it out for the longest time. Good luck.
Forum: 5.9L V8 Specific Topics 05-07-2009, 04:40 PM
Replies: 2
Views: 857
Posted By crg1987
Also make sure your cap didn't come loose and...

Also make sure your cap didn't come loose and twist to the point where the computer can no longer adjust the timing.
Forum: Electrical 05-07-2009, 04:35 PM
Replies: 3
Views: 480
Posted By crg1987
Fuel Problems

I've got a 1999 Ram 1500 4X4 and I just rebuilt the motor and it drove fine for a thousand miles, but now it feels like it's not getting enough fuel. Has enough pressure at the fuel Rail, the...
Forum: Newbie Checkin! 05-07-2009, 04:28 PM
Replies: 16
Views: 825
Posted By crg1987
New Member

Hey Im new to this site, but I've had a Dodge for a few years now up in Northern California.
Showing results 1 to 17 of 17

 
Forum Jump


Advertisement






All times are GMT -4. The time now is 01:32 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors