DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Search Forums


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Showing results 1 to 7 of 7
Search took 0.03 seconds.
Search: Posts Made By: 1998ram2500
Forum: 5.9L V8 Specific Topics 04-24-2013, 01:08 AM
Replies: 11
Views: 1,166
Posted By 1998ram2500
It is your front O2 sensor

Trust me, my 98 2500 did the same thing. The O2 sensor makes the IAC misbehave, also check for a plenum gasket leak which may have killed your O2 sensor.

Good luck
Forum: 5.9L V8 Specific Topics 08-30-2012, 06:50 PM
Replies: 5
Views: 1,583
Posted By 1998ram2500
Something to try

Ok next time you start it cold let it run at idle until it starts to act up. Do not give it gas. Turn the engine off and then immediatly restart the engine. If the engine starts up and runs smooth...
Forum: 5.9L V8 Specific Topics 08-30-2012, 02:56 PM
Replies: 5
Views: 1,583
Posted By 1998ram2500
Questions

A little more detail would be helpful to be able to understand just how this condition develops and resolves. Does the rough idle start imediatly or does the engine have to warm up for a minute or...
Forum: 5.9L V8 Specific Topics 07-16-2012, 04:00 PM
Replies: 6
Views: 678
Posted By 1998ram2500
Sounds familiar

It sounds much like a problem I just fixed on my 2500. The upstream O2 sensor controls a bunch of fuel and air related stuff from shortly after startup until the engine is hot. When that O2 sensor...
Forum: 5.9L V8 Specific Topics 07-15-2012, 01:19 AM
Replies: 6
Views: 1,746
Posted By 1998ram2500
Thumbs up Solved

I did alot of internet searching and finaly found a post by a Dodge mechanic that solved the issue. The upstream O2 sensor was bad. He explained that the engine will run fine for upto 2 minutes and...
Forum: Newbie Checkin! 07-12-2012, 05:25 PM
Replies: 6
Views: 261
Posted By 1998ram2500
My 1998 2500 and I say hi

Hello and thank you for the future help I am sure I will recieve. I just bought a 98 2500 long bed quad cab SLT with the 5.9 Gas AT 4x4 and so far I am happy. I do however like many people have a...
Forum: 5.9L V8 Specific Topics 07-12-2012, 04:42 PM
Replies: 6
Views: 1,746
Posted By 1998ram2500
Any solution?

I have a 1998, 2500 with the exact same problem. Any clues would be appreciated.
Thanks
Showing results 1 to 7 of 7

 
Forum Jump


Advertisement






All times are GMT -4. The time now is 12:17 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum