DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Search Forums


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Showing results 1 to 25 of 27
Search took 0.03 seconds.
Search: Posts Made By: B1500ram
Forum: Heating & Cooling 08-06-2014, 04:31 PM
Replies: 7
Views: 139
Posted By B1500ram
Talking Good news

Just wanted to update on the truck. So this was pretty frustrating and as I mentioned the tstat I bought was bad, maybe i caused that by overheating. It seemed to be opening up at really high temps,...
Forum: Heating & Cooling 08-04-2014, 07:11 PM
Replies: 7
Views: 139
Posted By B1500ram
Elaborate please. The other response is correct...

Elaborate please. The other response is correct in that you must remove the dash, blend door issues are common in these trucks.

Example: If you have it set to high for instance and air comes out...
Forum: Heating & Cooling 08-04-2014, 07:04 PM
Replies: 7
Views: 139
Posted By B1500ram
Thumbs up NO issues before pump went out. I thought about...

NO issues before pump went out. I thought about the air pocket for sometime, turns out the tstat was bad from the start. So now I learned a lesson to always check a new tstat before the instal!
...
Forum: Heating & Cooling 08-04-2014, 01:32 PM
Replies: 7
Views: 139
Posted By B1500ram
Water pump, clutch fan, tsat still overheating

Okay guys starting a new thread here.

My water pump failed while driving. I replaced the water pump, clutch fan, and tstat all at Autozone. The tstat is a 195 degree Fail Safe, the clutch fan is a...
Forum: Heating & Cooling 08-01-2014, 10:07 PM
Replies: 2
Views: 98
Posted By B1500ram
FYI, So definitely goofed on this one, while in a...

FYI, So definitely goofed on this one, while in a hurry to finish I installed the tstat in reverse. I switched it around, and temp is still somewhat high. Usually the temp runs just below the middle...
Forum: Heating & Cooling 08-01-2014, 12:32 PM
Replies: 2
Views: 98
Posted By B1500ram
So i realized the tstat was not in the incorrect...

So i realized the tstat was not in the incorrect orientation, jiggle valve down, I adjusted it to the 12 oclock position. But, still overheating, seems there has to be a bubble somewhere. I just put...
Forum: Custom Dodge Ram Performance Mods - Engine - 5.7 HEMI V8 07-31-2014, 07:06 PM
Replies: 9
Views: 2,902
Posted By B1500ram
Hey guys, i replaced my water pump and thermostat...

Hey guys, i replaced my water pump and thermostat today, but truck is overheating and the lower rad hose is cold to touch while upper hose is very firm and HOT! overheating. I have been trying to...
Forum: 4.7L PowerTech V8 Specific Topics 07-31-2014, 06:10 PM
Replies: 5
Views: 152
Posted By B1500ram
Same issue, for a long time, idle surge, used to...

Same issue, for a long time, idle surge, used to die, now it wants to accelerate while I am on the brake. No codes, my uncle is a mechanic and he said to replace TPS even if you aren't getting a...
Forum: Heating & Cooling 07-31-2014, 05:39 PM
Replies: 19
Views: 24,568
Posted By B1500ram
Dont want to beat this thread to death but: I...

Dont want to beat this thread to death but:
I have had the pleasure of my blend doors failing twice, about 4 years apart. The first one i threw a fit at the dealer and Chrysler paid for the entire...
Forum: Heating & Cooling 07-31-2014, 05:27 PM
Replies: 2
Views: 98
Posted By B1500ram
Replaced water pump, now overheating

Hello all , been sometime since last here.

I replaced the water pump on my 2003 Ram 1500 after it blew up on me, i also replaced thermostat and fan clutch, and belt.

It seems the thermostat...
Forum: 4.7L PowerTech V8 Specific Topics 02-21-2013, 01:26 PM
Replies: 13
Views: 1,315
Posted By B1500ram
sorry for the delay as i have been out of town, i...

sorry for the delay as i have been out of town, i did replace the upstream 02 sensor, ran for about 100 miles, then checked mpg. It is still around 10.5 mpg. I have not replaced spark plugs for a...
Forum: 4.7L PowerTech V8 Specific Topics 01-23-2013, 12:49 PM
Replies: 13
Views: 1,315
Posted By B1500ram
alright guys, thanks for all advice. NAPA told me...

alright guys, thanks for all advice. NAPA told me that the O2 sensor, or any sensor for that matter would flash a code. All I have is P0463 or something, it means the voltage to the fuel sending unit...
Forum: 4.7L PowerTech V8 Specific Topics 12-29-2012, 03:50 PM
Replies: 13
Views: 1,315
Posted By B1500ram
Thanks so much, I was hoping you were going to...

Thanks so much, I was hoping you were going to comment on this one! Guy at the auto shop said if it were a faulty sensor I would get a light and code. But, I have suspected it could be an 02 sensor...
Forum: 4.7L PowerTech V8 Specific Topics 12-28-2012, 02:50 PM
Replies: 13
Views: 1,315
Posted By B1500ram
Still nothing new and still puzzled. As...

Still nothing new and still puzzled. As buzzvoodoo commented on siphoning, well, we have a foot of snow on the ground and i would be able to see foot prints if that were the case, but good call...
Forum: Electrical 12-28-2012, 02:39 PM
Replies: 1
Views: 231
Posted By B1500ram
Sure thing, but first join the club. My 03' 1500...

Sure thing, but first join the club. My 03' 1500 does same thing, except on 4x4 roads where its bumpy they work! Somewhere in the knowledge base on this site is an explanation on how to fix it (if i...
Forum: 4.7L PowerTech V8 Specific Topics 12-23-2012, 12:43 PM
Replies: 13
Views: 1,315
Posted By B1500ram
Thanks for the advice, hopefully its a cheap fix,...

Thanks for the advice, hopefully its a cheap fix, good idea on the siphoning but i am certain that is not happening. I will look into what you have said. As I said before, i hope its inexpensive. I...
Forum: 4.7L PowerTech V8 Specific Topics 12-17-2012, 10:50 AM
Replies: 13
Views: 1,315
Posted By B1500ram
Help...Sudden loss of fuel economy!

So i have recently had a sudden loss in fuel economy, i have an 03' 4.7 and it is sucking fuel like crazy. I usually can expect 300 miles or so to a tank and now i am at around 200. I have ran 2...
Forum: Electrical 10-20-2011, 11:07 AM
Replies: 2
Views: 396
Posted By B1500ram
I have had a similar issue, ALL lights flashing...

I have had a similar issue, ALL lights flashing like fireworks (interior/exterior), engine dying and real rough running, make it a mile and jump it again. I am sure you have checked your battery...
Forum: 4.7L PowerTech V8 Specific Topics 10-11-2010, 01:50 PM
Replies: 13
Views: 8,009
Posted By B1500ram
So I am having the same issue with my 2003 131K...

So I am having the same issue with my 2003 131K 4.7L. It is having a rough idle and even died the other day. This happened before and dealer replaced throttle control sensor and it fixed the issue...
Forum: Electrical 05-04-2010, 04:48 PM
Replies: 12
Views: 2,801
Posted By B1500ram
Okay, the "key dance" worked. Thanks crabman. I...

Okay, the "key dance" worked. Thanks crabman. I am getting (P-0463), I will try to do some research on what this means. Do you know Remerson?, hope all in well in TN with the floods!
Forum: Electrical 05-03-2010, 09:23 PM
Replies: 12
Views: 2,801
Posted By B1500ram
Thanks, I will check the driverside switch, makes...

Thanks, I will check the driverside switch, makes sense.

As far as the P or U codes, I am not sure exactly. I took it to autozone, and the guy told me it was something to do with the fuel level...
Forum: Electrical 05-01-2010, 07:10 PM
Replies: 3
Views: 4,090
Posted By B1500ram
look in the knowledge base, i recall seeing...

look in the knowledge base, i recall seeing something about how to do that
Forum: Electrical 05-01-2010, 03:58 PM
Replies: 8
Views: 1,664
Posted By B1500ram
I had this problem, for me it was as simple as...

I had this problem, for me it was as simple as cleaning my battery connections. My whole inst. cluster would go off like fireworks, and my head lights as well. It even died sometimes.
Forum: Electrical 05-01-2010, 03:15 PM
Replies: 12
Views: 2,801
Posted By B1500ram
Ya, the lock is not engaged, when the windows do...

Ya, the lock is not engaged, when the windows do work you have to mess with the switches a bit, but that was a while ago and now it seems they dont ever work. thanks for the help
Forum: 4.7L PowerTech V8 Specific Topics 05-01-2010, 01:20 PM
Replies: 2
Views: 4,322
Posted By B1500ram
flushing 4.7 liter radiator help?

So yesterday i attempted to flush my coolant. I drained it from the radiator, then i tried to remove the block drain plugs and they were seized up pretty good, i stoped so as not to break them or...
Showing results 1 to 25 of 27

 
Forum Jump


Advertisement






All times are GMT -4. The time now is 01:36 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum