DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum - Search Results
DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums & Owners Club! - Ram Truck Forum > Search Forums


Notices


Vendor Highlight! - Check these guys out for great deals on Parts and Accessories!
Showing results 1 to 8 of 8
Search took 0.00 seconds.
Search: Posts Made By: overtheedge86
Forum: 5.2L V8 Specific Topics 09-23-2013, 08:18 PM
Replies: 7
Views: 769
Posted By overtheedge86
What you see in the pic was manually cleaned out...

What you see in the pic was manually cleaned out with a brush and shop vac. Also flushed some 2 stroke gas with the pan off to cut the crud. I have had the pan off 3 times now to clean the pick up...
Forum: 5.2L V8 Specific Topics 09-22-2013, 09:05 PM
Replies: 7
Views: 769
Posted By overtheedge86
Sludge was the problem, I think the seafoam...

Sludge was the problem, I think the seafoam knocked some other stuff loose from the nooks and crannies. I dropped the pan and cleaned the sludge out of the pick up. Started up with GREAT pressure...
Forum: 5.2L V8 Specific Topics 09-10-2013, 11:47 AM
Replies: 7
Views: 769
Posted By overtheedge86
Maybe a little more info. I bought this truck...

Maybe a little more info. I bought this truck about a month ago. It had sat for 2 years inside a garage with out starting. I changed the oil and all fluids after purchasing and the oil was...
Forum: 5.2L V8 Specific Topics 09-09-2013, 06:29 PM
Replies: 7
Views: 769
Posted By overtheedge86
Oil pressure reads 0!!!

Replaced the sender as well as add a mechanical gauge teed into the factory sender. Replaced oil pump due to it still reading low. yesterday drove about 100 miles and once hot would read about 10-12...
Forum: 5.2L V8 Specific Topics 09-01-2013, 08:03 AM
Replies: 2
Views: 390
Posted By overtheedge86
Well this morning i unplugged and checked the cam...

Well this morning i unplugged and checked the cam and crank sensors, then the coil. Plugged them back in and she fired right up? I'm thinking either the cam or crank sensor is on its way out.
Forum: 5.2L V8 Specific Topics 08-31-2013, 05:19 PM
Replies: 2
Views: 390
Posted By overtheedge86
motor wont wont start need help!!!

I picked up a Ram that had been sitting for a few years. drained tank, all fluids, replaced cap and wires. It was running ok a little rough but running. Today i drove it into the barn to replace...
Forum: Suspension 08-25-2013, 08:08 PM
Replies: 4
Views: 952
Posted By overtheedge86
Thanks for the reply, I was actually looking to...

Thanks for the reply, I was actually looking to stiffen the suspension for so than lift the truck. I don't like how much a loaded trailer squats my truck. May just add a leaf and level kit the front.
Forum: Suspension 08-25-2013, 01:18 PM
Replies: 4
Views: 952
Posted By overtheedge86
2500 coil springs on 1500 2WD

I've read of guys doing this on a 4x4 RAM but I'm wondering if it would work the same for a 2wd. The local scrapyard has a 2500 2wd and I'm thinging of grabbing the front springs/shocks and doing an...
Showing results 1 to 8 of 8

 
Forum Jump


Advertisement



All times are GMT -4. The time now is 07:45 PM.


Copyright © VerticalScope Inc. All rights reserved.
Powered by vBulletin® Version 3.8.10
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors