DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Search Forums
Register Advertising Gallery FAQ Members List Calendar Search Today's Posts Mark Forums Read


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Showing results 1 to 7 of 7
Search took 0.01 seconds.
Search: Posts Made By: Tracks Cdn
Forum: Electrical 03-01-2013, 12:15 PM
Replies: 1
Views: 325
Posted By Tracks Cdn
Can't believe no one has a answer for this. I've...

Can't believe no one has a answer for this. I've asked this question for 3 years with no response ?????
Forum: Electrical 02-07-2013, 02:45 PM
Replies: 1
Views: 325
Posted By Tracks Cdn
Cool cruise works intermittent

2004.5 Cummins 3500 crew cab non-dually
Crusie control will engage when on flat, soon as any uphill cuts out and won't enguage again until truck shut off and restarted.
1. replace servo with...
Forum: Cummins Diesel Specific Topics 07-16-2011, 11:17 AM
Replies: 3
Views: 1,718
Posted By Tracks Cdn
In 1000 kms (700 miles) burns almost 2 liters...

In 1000 kms (700 miles) burns almost 2 liters (quart and 1/2 US)
Truck runs perfect, bought it used 280,000 Kms (150,000 miles) maybe had a programer and someone drove the $hit out of it ??? Gets...
Forum: Cummins Diesel Specific Topics 04-07-2011, 03:04 PM
Replies: 3
Views: 1,718
Posted By Tracks Cdn
Cool 2004.5 5.9L oil consumption

Don't see any leaks, yet I add oil every 1000 kms (Canada eh)

Do I hook onto something heavy and get it good and hot? (had 2 Dodge service managers tell me that and 2 other H/D techs)

Truck...
Forum: Electrical 09-26-2010, 08:16 AM
Replies: 15
Views: 8,509
Posted By Tracks Cdn
Well after no replies on here I took it to...

Well after no replies on here I took it to dealership they checked it and told me it's the servo.
Very common problem. I'm suprised no one on here commented:4-dontknow:
Forum: Electrical 09-18-2010, 11:15 AM
Replies: 15
Views: 8,509
Posted By Tracks Cdn
Cool cruise

Bump, bump
Forum: Electrical 09-17-2010, 11:59 PM
Replies: 15
Views: 8,509
Posted By Tracks Cdn
Cool my cruise

04 3500 4x4 auto Set cruise works for 10 seconds then cut out and won't work again.?????? Cruise indicator come on and of when switch is used to turn on and off.
I was thinking maybe brake pedal...
Showing results 1 to 7 of 7

 
Forum Jump


Advertisement






All times are GMT -4. The time now is 08:56 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
vB.Sponsors