View Single Post
  #1  
Old 02-15-2013, 11:33 PM
Lonestar Lonestar is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2013
Location: Alberta, Canada
Posts: 1
Gender: Male
Vehicle: 2011 Ram 1500 Sport 4x4
Trim Level: Sport
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Lonestar is on a distinguished road
Default 1997 1500 4x4 5.2L low/rough idle and stalling

Hey everyone, new to the dodge scene but loving it so far. My daily is a 2011 1500 CC 5.7 4x4 and thankfully its been flawless since I bought it.

My other toy is a 1997 1500 4x4 with a 5.2/ 5-speed. Its got 212,000km's and is a fairly solid truck all around. Since I picked it up I've noticed it had a low/rough idle and will stall occasionally when decelerating or coming to a stop.

I've searched around for typical causes for this and have so far come up with nothing to solve it. I've done the following repairs/diagnosis so far:

-resealed the plenum gasket and cleaned tb with the hughes kit. runs smoother, but no change for low idle.
-checked vacuum lines for leaks (except where they enter the cab through the firewall) couldn't find any issues
-tested for faulty idle speed motor with new solenoid, no difference
-tested voltage, signal and ground on tps and map sensors, both checked out to the best of my knowledge.
-changed out intake charge temp sensor, no change
-new plugs, wires, cap/rotor

KOEO self test came up with these codes:

12-15-25-42

Dunno what else to do, and like I said these are the first dodge trucks I've ever owned so I'm still learning the mopar tricks and basics.

Any input to help me getting this truck running smoother would be great. I'd rather beat on my 2nd gen since it already has a 6 inch lift and 37's. My 4th gen is too pretty to bag or take mudding.

Thanks in advance
Reply With Quote
Sponsored links