View Single Post
  #47  
Old 03-04-2013, 04:00 PM
InDeepWaterBlue's Avatar
InDeepWaterBlue InDeepWaterBlue is offline
Dodge Ram Forum Senior Member!

 
Join Date: Feb 2012
Location: Florida
Age: 26
Posts: 3,953
Gender: Male
Vehicle: 2011 Dodge Ram Big Horn
Trim Level: Big Horn
Color: Deep Water Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 5
Rep:611
InDeepWaterBlue is a name known to allInDeepWaterBlue is a name known to allInDeepWaterBlue is a name known to allInDeepWaterBlue is a name known to allInDeepWaterBlue is a name known to allInDeepWaterBlue is a name known to all
Default

Quote:
Originally Posted by sylster View Post
well, I've had the truck for about a week and it's back to the shop. I'd notice a vibration that seemed to start at about 87KM/h and didn't know what it was....I drove it for a few days thinking it might be the roads as they are really rutty lately. Well. The vibration didn't go away and is present from about 90km/h and constant to well over 140km/h....so it went back...there is definitely something outta whack...They took it out for a test drive and think it might be the wheel bearing on the opposite side that got hit. I dunno....but they better find the issue or they will get it back, and back, and back until it's right. It wasn't there before and sure as heck I'm not going to be satisfied until it is 100%.

Paint is fine and bedliner was redone....so it's just mechanical now hahaha

S.
Well $h!t Hope they figure out what it is, and I'd take it back until it was perfect. When I messed up my truck, they redid the alignment and I would rub the swap bar at full right lock. And I took it back to them to have it redone
Reply With Quote