View Single Post
  #174  
Old 03-14-2013, 03:07 PM
EZStreet8 EZStreet8 is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2013
Location: Oakville, Ontario, Canada
Age: 64
Posts: 26
Gender: Male
Vehicle: 2013 Dodge Ram 1500 Laramie
Trim Level: Laramie
Color: Bright White/Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
EZStreet8 is on a distinguished road
Default

Thanks Ram725 and Grubrunner,
Greatly appreciated.....Just wanted to double check with you, B4 I pull the trigger, it was the oiled filter, the cleanable one you suggested....not the dry filter....right.

Just remembered, I've got a Hypertech Interceptor #705003 for the 2013 model. Apparently the 2013 has different connectors than earlier model. I'd like to do a few runs 0-60 mph bone stock and after then with the CAI and then with the CAI & Chip.
I'd like to do a progression as I add equipment....like CAI, Chip, Exhaust just to see
how it all works together. I'll probably also add the rear air bags from Total Load Control at some point this spring or summer and see if that improves the launches
with the added traction it should provide.....should be fun.

Just a tip from my motorcycle riding hobby....I ride a Honda CBR 1000 RR with a double bubble wind screen on it and I use a plastic cleaning product called Plexus to clean my helmet visor and the windscreen on the bike and they both look like they just came out of the box ....brand new...no marks perfectly clear...not even swirl marks, it works amazingly well. I even clean my motorcycle with it to get the bugs off before every ride. Will keep the S&B window looking like brand new, if you use it regularly with a clean microfiber cloth.

Happy Motoring....EZ
Reply With Quote