View Single Post
  #1  
Old 03-23-2013, 04:57 PM
KevinGoodyear KevinGoodyear is offline
Dodge Ram Forum Junior Member
 
Join Date: May 2012
Location: Denton Texas
Age: 50
Posts: 34
Gender: Male
Vehicle: 2009 Dodge Ram Laramie 4x4
Trim Level: Laramie
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
KevinGoodyear is on a distinguished road
Default Spark Plug change and AC problem

I made a post about this...but dont think I did it in the right place..I will try again...I changed my plugs earlier in the week, moved the AC low pressure line over a little bit, really just a hair, and then the next day I had NO AC AT ALL!! Leaked out all my R134a behind the expansion block/valve. The AC oil leaked out down to my frame rail. I removed the block/valve and saw where the lower torx screw was loose and corroded (the top torx bit look better and was much tighter). I ordered the 4 new O rings from the dealership and reinstalled AND cleaned the torx screws and replaced. I added three cans of R134a (just temporary till I KNOW its not leaking anymore). My wife is driving the truck and will return tomorrow...sure hope the block isnt leaking behind it anymore. If not I will have the AC system sucked/dried and recharged the correct way...this is just temporary. The dealership said I cracked the evap core and...well, you know what they said next right??!! But that evap core lines are/were so dang tight I dont feel that I broke the evap core connections...I mean, I didnt yank and pull and push the low side line...just moved it over about a hair...any ideas? Kevin in Dallas
Reply With Quote
Sponsored links