View Single Post
  #21  
Old 05-05-2013, 09:08 PM
Zimpete Zimpete is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2013
Location: Minnesota
Posts: 7
Gender: Male
Vehicle: 1999 Dodge Ram 2500
Color: White
Engine: 1994-2001 488ci (8.0L) LA V10 300 hp 450lb/ft
Rep Power: 0
Rep:10
Zimpete is on a distinguished road
Default

Took the truck to O Riley's and they checked for codes and found none. They looked up O2 sensors and said there are many options. Could have either 2 or 4. I went to Napa where I know and trust most of the guys that work there. They only listed 4 O2 sensors for a 99'.

I bought the front 2, closest to the exhaust manifolds and went home to install them. I then found 2 other connections above the transmission for additional sensors but my truck only has 2. I called an older mechanic I know and he said if my truck were an early build 99' it may only have 2 because he thinks 98' only has 2. This could be why when I looked into replacing the computer I found there were 3 different ones and no one was able to order the one I needed, it was rebuild only.

I installed both sensors on Saturday and after 3 short trips so far everything is working great.

I talked with our trainer at work Friday(I am a forklift mechanic) and he said if my O2 sensors are 4 wire they are more than Likely heated sensors and that could be why it runs like crap in closed loop until they get to correct operating temp.

I want to thank everyone for all the help and I will update this in a couple of days to let you know if everything is ok.
Reply With Quote