View Single Post
  #4  
Old 05-29-2013, 07:49 AM
starquestbd22's Avatar
starquestbd22 starquestbd22 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2011
Location: NC
Age: 32
Posts: 2,556
Gender: Male
Vehicle: 2004 Dodge Ram 1500 4X4
Trim Level: Sport quad cab
Color: Bright Silver Metallic
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 5
Rep:360
starquestbd22 is just really nicestarquestbd22 is just really nicestarquestbd22 is just really nicestarquestbd22 is just really nice
Default

I second (or third, whatever) what has been said. Clean your throttle body well and check everything you can see while you are doing it. It's very odd that it only started when you fabbed up your intake. Not saying you did anything wrong but if your issues started immediately after......have you considered returning it to stock to see what happens? At least go back and double check all your work.

I assume by ETC you are referring to the electronic throttle control? So you are getting the little lightning bolt symbol lit up in the cluster? I really don't think this is an extremely common problem. I have read about a handful of people seeing the lightning bolt but nowhere near enough for it to be considered a recurring issue with these trucks. Regardless, Chrysler isn't going to do a recall on a 9 year old vehicle anyway so I wouldn't get my hopes up about that.

Let us know how the TB cleaning and recheck of everything goes.
__________________
06-08 chrome clads w/33" Cooper Discoverer H/T Plus, Mopar tailgate spoiler, debadged door trim & tailgate emblems, 13" antenna, LED dome & maps, Magnaflow 22" SI/DO, 18% tint, "HEMI" hood spears, VHT tinted tails & third brake light, Lamin-x optic blue fogs, leveled w/McGaughys 2" drop shackles.
Reply With Quote