View Single Post
  #1  
Old 06-02-2013, 09:39 AM
MeanMango MeanMango is offline
Dodge Ram Forum Junior Member
 
Join Date: Mar 2011
Location: LA
Age: 32
Posts: 36
Gender: Male
Vehicle: 2014 Ram 2500 4x4
Trim Level: Bighorn
Color: Maximum Steel
Engine: 2013-20?? 409ci (6.7L) Cummins Turbo Diesel 370hp 800lb/ft (6-Speed Automatic)
Rep Power: 0
Rep:46
MeanMango is on a distinguished road
Default Air Conditioner Problem

A few weeks ago I was on a long drive to Houston. About an hour and a half into the drive I started hearing a clicking noise coming from the passenger side under the dash. Then it started getting warm in the truck. I could hear the fan blowing, but only a tiny bit of air was blowing through the vents. It didnt matter what I had the climate control set on, even if I tried manual control.

I found out about the actuator recall thanks to this site so I took it to the dealer and they checked it and it was bad. Another trip to the dealer and they replaced it. They could not flash the ECM because their computer was broken.

It all seemed fine until yesterday (my longest typical drive is an hour) when I was on another 3 hour drive. About an hour and a half in the clicking started and hardly any air was coming out of the vents. On the way home I decided to use manual controls to see if that would work the whole way. I set both sides to Lo and put the fan on full blast. About 2 hours into the drive, it started messing up.

Shutting the truck off for a few minutes when it does this will stop the problem for a few minutes. It seems something it getting hot? It sounds like the blower is still running but the air just cant make it to the vents. Any idea on what else the problem could be? If its a relatively cheap repair I just assume do it myself. Time is money and two trips to the dealer and a few hours off work is hardly worth a $40 repair.
Reply With Quote
Sponsored links