View Single Post
  #94  
Old 06-26-2013, 02:00 PM
dodgeboy360's Avatar
dodgeboy360 dodgeboy360 is offline
Dodge Ram Forum Senior Member
 
Join Date: Mar 2012
Location: windsor ontario
Age: 24
Posts: 863
Gender: Male
Vehicle: 2015 Dodge Ram
Trim Level: SXT
Color: Granite
Rep Power: 5
Rep:505
dodgeboy360 is a glorious beacon of lightdodgeboy360 is a glorious beacon of lightdodgeboy360 is a glorious beacon of lightdodgeboy360 is a glorious beacon of lightdodgeboy360 is a glorious beacon of lightdodgeboy360 is a glorious beacon of light
Default

Quote:
Originally Posted by Hemi N Haw View Post
Hey dodgeboy I appreciate the explanation since I didn't understand initially. I had an old monte carlo & swapped in a 4.3 v6 to replace the original one that took a crap. The money was the issue at the time so I went a real cheap route & picked up a 4.3 from a boat yard that I worked at. I swapped the intake but not the cam from my old 4.3. It was an old tbi motor. The computer wasn't reading her right so she was dumping fuel in at a higher rate due to a boat making more use of higher rpm. I never did anything to compensate & wham the engine blew due to the fuel washing them cylinders down at a faster rate. So I get it now. Sorry I was such a dumb ass. I forgot old cliffs original threads where he mentions the truck miss firing & the plugs being all fouled up. Yea & in regards to cliffs dilemma. I too feel the tuner is the culprit if so I wonder who else has had issue w/ theirs, bully dog or diablo?
It's all good I didn't explain good enough the first time.. And yes that's exactly what I'm thinking/ assuming happened to cliff it's the only thing that makes sense to me..
__________________
2015 Ram 1500 crew cab 4x4 Hemi
Trailer tow package, timbrens, husky liners, k&n drop in, roll up cover, 14" magnaflow w/4" stainless tip
Reply With Quote