Thread: BD review imo
View Single Post
  #1  
Old 07-21-2013, 12:48 PM
gsxrfarm's Avatar
gsxrfarm gsxrfarm is offline
Dodge Ram Forum Junior Member
 
Join Date: Jun 2012
Location: arkansas
Posts: 48
Gender: Male
Vehicle: 2012 ram express
Trim Level: express
Color: white
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:47
gsxrfarm is on a distinguished road
Default BD review imo

well I have had my bd for a few weeks now and have played with it and tried to set it what I want and to how I drive , I drive a lot of hwy miles so im looking for more mpg and this is what I have came up with start to finish ...First off I have 2012 express , 20" factory wheels , 18" magnaflow , s&b cai .and 27xxxmiles .After opening the bd and trying to follow the the instructions to download the tune I found that "bullydog agent " didn't have the option to select my truck, so I called bd and they sent me the new update , I uploaded it and was able to find my truck there. if it wasn't for the forum and others on here saying they had to call I woulda been lost. so I chose the premium tune the first time , set both of my shift points to 5840 took it up the road and ran it a few times , ran like a beast no doubt but it seemed to fall down right before it shifted but I still left it. I fueled up at shell with 93 oct which I always run and started my test I drove it to work and home for 3 days a trip a day was 95miles round trip(10miles hills 35-55mph, rest was hwy.65-74mph). after the first day the trip to work in the morning was fine truck was pulling great and seamed to have no issues , but on the way home in the hills I was lagging it as always about 38-42mph and heard a "clinging" knocking whatever it was labor knocking so I pulled up the timing on the screen the next day , and again under a load it did the same thing the timing was at 24'. well on the final day I decided to punch in while it was under load on a straight stretch and nothing.
I went home and put it back stock and changed it to the regular tune set my shift points at 5800 ran it a few passes as I did the other one and found that you can turn the tc off on the programmer and wow a huge difference the truck was running like crazy. well once again I fueled it up 93oct shell same station and all , ran the same thing to work as always well the truck did just as well couldn't tell any diff driving on the hwy. when I got to the hills the same thing happened again the laboring was back just a little lower mph and the timing was at 22' ..

My over all experience with it is this installation was easy but they need to get the updates set up right for the agent the over all mpg in the premium tune was 17.2, the regular tune was 18.1 that's what I figured it at. I was hoping for more out of the MPG but a little is better than none , the performance was great A+++++ in both settings I cant see anyone being upset for it being a truck ..

but now to the labor knock is there anything I can do to fix that , maybe a tstat to bring the temps down a little , or I have seen people state a catch can but I don't understand what diff that will make.
__________________
2012 express , s&b cai, magnaflow, bullydog, catchcan 24" rims
Reply With Quote
Sponsored links