View Single Post
  #1  
Old 08-11-2013, 09:00 PM
Magnum164 Magnum164 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Posts: 4
Gender: Male
Vehicle: 2004 Dodge Ram 3500 4X4 DRW
Engine: 2004-2004 359ci (5.9L) Cummins ISB 600 24-Valve Diesel I6 325hp 600lb/ft
Rep Power: 0
Rep:10
Magnum164 is on a distinguished road
Default P2509 truck will not start

New to the forums and also new to a diesel Ram. I have a 2004.5 3500 4x4 DRW that the radiator went out in, actually the drain plug would not seal. So I replaced the radiator this weekend. Also, since the previous owner had put in 100hp injectors and the truck was using a very old Edge system I decided to upgrade and went with a Banks Economind. I know a lot of people are not fond of Banks, but for what I want the truck to do, the unit will work fine. Already have a Banks air and scoop kit and tomorrow will start installing the a new Banks intake and intercooler.

However, when I hooked up the Banks it connected to the cam/crankshaft sensors. The Crankcase showed signs of corrosion so I replaced it. The truck cranked and when I put it in gear it went dead, completely shut down.

The gauges are not working and it throw the code P2509. The Banks unit shows no errors.

I removed the connections to the old thermocoupler and the gauges started working and it cranked. Thought I had it fixed, but after 1 minute of idling it went dead and the gauges are no longer working.

Will call Banks next week. But anyone have any idea what could be wrong? I don't think it is the Banks unit (yet), I suspect something in the ECM went out.

I have looked over all my connections and can not find any loose or shorted connections.

The good news? The radiator no longer leaks
Reply With Quote
Sponsored links