View Single Post
  #1  
Old 08-12-2013, 10:10 AM
USAF Long's Avatar
USAF Long USAF Long is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2013
Location: Salt Lake City, UT
Age: 32
Posts: 374
Gender: Male
Vehicle: 2013 Ram 1500 RCSB
Color: Red
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 0
Rep:69
USAF Long will become famous soon enough
Send a message via AIM to USAF Long
Default Ran my truck at Tri-State Dragway

I made about 10 runs. The track was not busy but it wasn't prepped good at all. There was no VHT. Just water and rubber that was it.

My first run was my best. I think it was 14.96@90mph. I turned off traction control, used tow/haul mode, and left it in drive. Skipped the water box, and just punched it and ran.

That was my only 14 second run of the day. I tried the tow/haul off, burning out a bit, stalling up the converter, tried the other lane, lowered my tires to 25 psi out back, manually shifted 1-2-3...

Best MPH was keeping it in 3rd (2nd prime) and I got a 93.98 mph. All the rest of my times were between 15.0-15.45 and anywhere from 90-94 mph.

I want to get on another track thats closer that has new surface and they spray VHT on the starting line. My 60' times were all 2.2-2.4 and I was spinning every time which I can't even do on the street. The damn rubber on the track was hurting my traction.

I had the spare and jack and tailgate removed. Air filter removed, 1/4 tank of 93 octane.

Only modification I have done is replaced the factory muffler with a Magnaflow Y-pipe.

Here's a video my girlfriend shot with my digital camera... the digital zoom sucks.

__________________
-Scott Long-
2013 Ram Express RCSB: 5% tint, de-badged doors, muffler delete y-pipe, K&N panel filter.
Best Run: 14.60@96mph with 2.4 60' at Kil-Kare Raceway in Ohio
Reply With Quote
Sponsored links