View Single Post
  #11  
Old 08-26-2013, 10:11 AM
Clinger Clinger is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Louisiana
Age: 42
Posts: 7
Gender: Male
Vehicle: 1998 Ram 1500
Trim Level: SLT Laramie
Color: Gray
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
Clinger is on a distinguished road
Default

I changed out the u-joints on the left and right axles coming out of the front diff to ward the wheels. I didnt address the u-joint between the transfer case and diff. I will look it it may be it is bad too.

This w/e I put the front end on stands and spun the wheels to see if I could isolate the noise. Seemed a bit to me like it was coming from the diff so I checked its fluid. Couldn't touch it from the filler hole. Ruh Roh! Fearing the worst I removed the cover. Good news is it that while it was very low it wasn't dry and there was no indication of damage. Whew! With the way my luck has been running lately I didn't think this was going to turn out well. So I am going to clean it up a bit and refill. Fingers crossed that this was/is the issue but I dont think so. Not sure why it was low either. The axle seals seemed fine as the interior of the axle housings were dry as a bone.

Next step is going to be swapping the hubs with the old ones one at a time to see if it is a bad hub.

I hear you on the torque issue. I will see what I can figure out to be get a wrench that will work and make sure things are right.
Reply With Quote