View Single Post
  #1  
Old 08-27-2013, 04:10 PM
kenwitter's Avatar
kenwitter kenwitter is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Mississauga, ON, Cananda
Age: 37
Posts: 12
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Laramie
Color: Blue
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
kenwitter is on a distinguished road
Default Can't select Heavy Electric on ITBC

I recently traded my 2010 1500 for a 2013, and had the dealer install the OEM Trailer brake controller. I cannot get it to change the braking power from light electric to heavy electric. The dealer's techs kept it for almost two days and were unable to figure the problem out, even with chrysler Canada's help.

I access my vehicle settings through my radio, Model: 8.4N (not 8.4AN, which isn't available for Canadian market). I have all 4 brake options listed and can select heavy electric, however my EVIC is only giving me a light electric setting. At a gain of 10 and with full braking power (Meter goes to 100%) I'm not getting enough stopping power.

I had an OEM brake controller in the 2010 and the only way I got full power to my trailer brakes was with the heavy electric setting.

What I know:

ALL Trailer brakes are fine and working (4 trailers all tandem axle)

I am getting some stopping power, just not enough.

Uconnect software version: 13.15.4

No error codes recorded during trailer towing (dealer verified)

I can select all 4 break power settings on the radio, however i should only be able to select heavy or light electric on the 1500. I should not be able to select either of the Hydrolic options.

Evic displays everything else to do with the controller properly, just not the heavy electric setting.

What I think:

Something, somewhere needs to be updated.

If anyone knows of a solution or has a suggestion, I could really use some help. REALLY frustrating, but I dont want to take it out on my guys at the dealer. Normally they are excellent.

If you have the OEM brake controller and are able to select the Heavy Electric type, I would greatly appreciated your EVIC and/or Uconnect software version number.

The pics below illustrate my problem.

Thanks

Ken
Attached Images
File Type: jpg uconnect.jpg (116.8 KB, 11 views)
File Type: jpg EVIC.jpg (122.1 KB, 12 views)
Reply With Quote
Sponsored links