View Single Post
  #1  
Old 09-12-2013, 11:39 PM
Fatherholyholy Fatherholyholy is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2013
Posts: 4
Gender: Male
Vehicle: 2001
Rep Power: 0
Rep:10
Fatherholyholy is on a distinguished road
Default No bus cluster Fudge

2001 Ram 2500 2wd. 5.9L Gas, Automatic with AC. No mods.

4 years ago the dash gauges went out and stayed that way for months until they magically fixed themselves.

Fast forward to last week. Truck sputters and stalls while driving. Sometimes it starts and sometimes it doesn't. Always cranks. Sometimes it displays no bus when it doesn't start and sometimes it starts with no message. No rhyme or reason to it. Only weird thing going on for the last month is the Power Steering has been going out periodically and for years I have been able to remove the key at any point from the ignition switch but not sure that either are related. Tried a code reader and it would not connect... I tried about five times and then it finally said no codes present.

Got home and used the key/odom code read and pulled a 0443. Checked vacuum tubes and could not find any cracks or leaks (didnt check top of gas tank). Swapped gas caps with my 03 to no avail. Replaced the vacuum vent purge solenoid. No change. Put the old one back in to look elsewhere for the problem.

Went on vacation but I was back out there today. Turned key with trip button pushed to check guages, all checked out with no codes. Checked connectors at PCM and ECM. Cleaned and greased. Started right up... while I was driving it ran fine for a mile and started sputtering again and almost died if I hadn't put it in neutral and rev'd a few times at the light. Ran like a top all the way home.

This time I got some new codes:

P0351 - Coil 1 not reaching peak current at right time

P1494 - Leak detection pump sw or mechanical incorrect input state detected for Leak Detection Fault Pump (LDP) pressure switch.

P1595 - Speed Control Solenoid Circuits. An open or shorted condition detected in either the speed control vacuum or vent solenoid control circuits.

P1687 - No MIC Bus Message. No CCD messages received from mechanical instrument cluster (MIC) module


So now I'm looking at testing the Leak Detection Pump, the speed control vacuum (where's this?) or headed back to the vent purge solenoid control circuits. Possibly getting a used PCM? Will head out tomorrow to pickup a Haynes.

Is there anywhere else you guys think I should be looking first? I have a long list that keeps getting longer. )=

Thanks for any and all help.

Last edited by Fatherholyholy; 09-13-2013 at 02:32 PM.
Reply With Quote
Sponsored links