Thread: Truck Problem
View Single Post
  #1  
Old 09-14-2013, 04:39 PM
phantombullet phantombullet is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Elizabeth City, North Carolina
Age: 53
Posts: 5
Gender: Male
Vehicle: 2003 Ram 1500 Quad Cab 4X4
Color: Charcol Grey
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
phantombullet is on a distinguished road
Default Truck Problem

Don't know where to put this so I'm gonna put it here and hopefully somebody out there can help!

I have a 2003 1500 Quad Cab 4x4 SLT 4.7. My problem is this:

I have no right turn signal, no 1st intermediate wiper blade function, high beam switch shoots washer fluid instead of high beams, washer push on side of switch doesn't do anything, headlights go out after anywhere from 5 to 10 miles, move headlight switch to "parking light position" to have headlights, 4 ways, won't turn off even after you unplug switch. (Left turn indicator works fine)

So far, I have changed 2 turn signal switches, one from Autozone and one from a Dodge dealer. Both work for about 5 minutes and then things go haywire! I just changed the Multifunction Chassis Control Module/Relay that sits on the side of the fuse box. After all this took the truck for a drive and 5 miles down the road everything went to you know where! I am on a limited budget so the dealer is out.....I had one guy hook up his $8000.00 Snap On code reader and it says open faults R/S light system. Also, I checked all bulbs, grounds from front to back!

If anybody can help me out, this Disabled Veteran will THANK YOU ALL VERY MUCH!!!

Thanks,

Bobby
Reply With Quote
Sponsored links