View Single Post
  #11  
Old 09-26-2013, 10:26 AM
starquestbd22's Avatar
starquestbd22 starquestbd22 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2011
Location: NC
Age: 32
Posts: 2,645
Gender: Male
Vehicle: 2004 Dodge Ram 1500 4X4
Trim Level: Sport quad cab
Color: Bright Silver Metallic
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 5
Rep:360
starquestbd22 is just really nicestarquestbd22 is just really nicestarquestbd22 is just really nicestarquestbd22 is just really nice
Default

When I cranked the bars on my 04 I got a slight shudder type vibe on heavy acceleration from a stop or low speeds. Never encountered anything at highway speeds or when holding any constant speed. That doesn't mean it isn't causing you problems....just my experience I had with my own truck. My guess is that the root problem is somewhere else and the level has simply elevated it to the point where you have noticed. I personally would start by having them balanced.

Also, just FYI, that appears to be your steering rack leaking rather than your pump/reservoir. Unless it's leaking from the bottom of the pump down onto the rack. Mine was actually leaking where the hoses connect to the bottom of the pump/reservoir unit when I bought it. I had to replace the hoses and also replaced the factory squeeze clamps with worm gear clamps....problem solved for me. Good luck!!
__________________
06-08 chrome clads w/33" Cooper Discoverer H/T Plus, Mopar tailgate spoiler, debadged door trim & tailgate emblems, 13" antenna, LED dome & maps, Magnaflow 22" SI/DO, 18% tint, "HEMI" hood spears, VHT tinted tails & third brake light, Lamin-x optic blue fogs, leveled w/McGaughys 2" drop shackles.
Reply With Quote