View Single Post
  #1  
Old 10-03-2013, 12:14 PM
01LaramieTank 01LaramieTank is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: Oklahoma
Posts: 2
Gender: Male
Vehicle: 2001 Dodge Ram
Trim Level: Laramie
Color: Black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
01LaramieTank is on a distinguished road
Default Need tranny and charging help!

I have a 01 Laramie with the 5.9, 4x4 auto transmission. Threw a few tranny related codes and got put into "limp" mode after driving in 4 HI on a very muddy road after heavy rains. The "check gauges" light came on as well, and it turns out that the battery is not being charged.
I don't have a lot of money to throw at this thing, so I'm asking for some help on here. I looked all over the internet, but haven't found much so far.
I checked for shorts, bad wires at the transmission connectors (park neutral switch connector was stripped), replaced transmission relay, replaced fluid and filter... After a few test drives the battery keeps dying. The battery gage goes to 0 and "check gauges" light comes on after driving for a little while, but not when I first start the vehicle. Also checked for parasitic drain, but found nothing.
I found a lot about governor sensors and solenoids, but other people are saying that that would not throw the electrical related codes... All of this points to the PCM from what I can find. I read somewhere the pcm tells the alternator to charge the battery when needed... The battery is almost brand new and I replaced the alternator since the old one had a rattle in it. I had both checked and they tested fine...
Here are the codes:
P0743: Torque converter clutch circuit - electrical
P0753: Shift solenoid
P1765: Transmission 12V supply relay
Also threw P1495, but my manual didn't list this for my ram... found it to be leak detection pump solenoid circuit...
Any help is welcome. Thank you!!!
Reply With Quote
Sponsored links