View Single Post
  #1  
Old 10-11-2013, 11:29 AM
BombDoc BombDoc is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: SC
Age: 47
Posts: 1
Gender: Male
Vehicle: 2011 Ram 2500
Trim Level: Laramie
Color: Deep Cherry Red Crystal Pearl
Engine: 2007-2011 409ci (6.7L) Cummins Turbo Diesel 350hp 650lb/ft
Rep Power: 0
Rep:10
BombDoc is on a distinguished road
Default 2011 Brake Controller issue

Hello, new to the forum as of today. Need some help/advice on how to figure out what is going on with my braking system. I have a 2500 Cummins 2011 Laramie. I also have a 2013 Palomino Sabre 5th Wheel loaded weight around 12000lbs. I have had the 5er since March. As of a month ago, while riding down the road towing, I get the dash chime, and "trailer brakes disconnected" message. It immediately resets and may take another 10 minutes before it does it again, or it could be 1 minute. I took the truck to the RV dealer who had a 7 pin connection tester. He plugged the tester into the bed outlet and the bumper outlet. Both were showing an intermittent power hit on the brake wire, 12V constant where it should have been, and a constant flicker on the brake wire. We both assumed it was the controller. I went to Dodge, spoke with the shop foreman and he thought it was the brake controller as well. I purchased a new controller and installed it last night. Hooked up the 5ver and took a test drive. Same issue. My controller says "SC" and almost immediately resets. Does anyone have any idea what might be the problem. I have attempted to turn the ignition on with the door open and wiggle wires in order to get the alarm to sound, no luck. All of the wiring around the bed receptacle and the bumper look great. I am at a loss and really don't want to get up to 70mph and need the brakes. I'm really tired of listening to the chime too. Any help would be greatly appreciated.
Reply With Quote
Sponsored links