View Single Post
  #1  
Old 12-08-2013, 07:01 PM
tdub2112's Avatar
tdub2112 tdub2112 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2011
Location: Idaho
Posts: 97
Gender: Male
Vehicle: 1996 Dodge Ram 1500
Trim Level: SLT Laramie
Color: Silver
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:16
tdub2112 is on a distinguished road
Default Truck dying while driving, but idles fine.

Well, I had this same problem last winter, but we fixed it. Problem is, I don't remember what fixed it.

This has only started since it's gotten cold, much like it did last year. My truck seems to hunt A LITTLE for an idle. It's not major shifts, but it's there. Performance is all there, runs great when it runs. It will still sit and idle to warm up for 10 minutes but after sometimes only 5 minutes or less of actual driving, the engine will die, and the oil pressure light will come on. I do have 10W-30 in instead of 5W-30 in right now, so that can effect things, but up until this past year, that has never been an issue.

I could understand getting low oil pressure at idle and the engine dying because it can't pump oil at a good enough rate, but when I have rpms up out driving i would think it would be fine.

So tomorrow (hopefully it warms up) I'll check out the IAC and see if it's clean. From what I understand it can get some carbon buildup and start acting erratically. Anything else I can do/look into. We have an OBDII code reader. Should I plug her in and see if anything is amiss there?

Thanks all!
Reply With Quote
Sponsored links